SPF record showing main shared ip not a custom ip address

iLinux85

Well-Known Member
Mar 28, 2010
52
2
58
Hello

I have shared hosting dedicated server . all accounts on main shared ip address x.x.x.x

one of the accounts I want to set custom SPF record. so I set this TXT value

Code:
"v=spf1 +a +mx +ip4:y.y.y.y ~all"
and I tried to send a message from one of the created emails of this cpanel account to gmail email account. i checked show original messages in gmail account and it showing

SOFTFAIL with IP x.x.x.x

i have SOFTFAIL message and also it doesn't show the changed IP address I made which is suppose to be y.y.y.y

so i tried this TXT value

Code:
"v=spf1 +a +mx +ip4:x.x.x.x +ip4:y.y.y.y ~all"
and sent another message to gmail and showing in show original SPF PASS but still showing main shared ip address

i changed the ip address of this Cpanel account and changed all values in dns zone file to y.y.y.y i set custom ip address in /etc/mailips still SPF showing the main shared ip address x.x.x.x

why spf record keeps showing main shared ip address even i changed site IP address and all dns zone values and made custom enty in /etc/mailips for this account?
 

quietFinn

Well-Known Member
Feb 4, 2006
1,222
88
178
Finland
cPanel Access Level
Root Administrator
Did you check Exim settings, in WHM -> Service Configuration -> Exim Configuration Manager -> Domains and IPs ?
 

iLinux85

Well-Known Member
Mar 28, 2010
52
2
58
yes both settings

Reference /etc/mailhelo for custom outgoing SMTP HELO
Reference /etc/mailips for custom IP on outgoing SMTP connections

Saved as On
 

quietFinn

Well-Known Member
Feb 4, 2006
1,222
88
178
Finland
cPanel Access Level
Root Administrator
You probably say "Of course I did" but I ask anyway: "did you restart exim after modifying /etc/mailips" ? :rolleyes:
 

iLinux85

Well-Known Member
Mar 28, 2010
52
2
58
yes i did restart exim services and run /usr/local/cpanel/scripts/updateuserdomains command still google seeing in show original the main ip address of the server