The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spoofed From Field

Discussion in 'E-mail Discussions' started by Keelan, May 8, 2015.

  1. Keelan

    Keelan Member

    Joined:
    Nov 16, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello, i am having issues with spoofed from fields.

    Now i know that there isn't much we can do technically. I keep seeing, it's like someone mailing somebody and putting my return address on the envelope.

    With that said:

    I have enabled SPF, DKIM, Boxtrapper and Spam Assassin.

    The biggest issues is i'm having is spoofed from addresses emailed to myself. e.g:

    random@randomspamwebsite.com with from field administrator@mydomain.com emails me@mydomain.com.

    Administrator@mydomain.com doesn't exist, but my boxtrapper and filters see the from address and think it is a local address and deliver it to me.

    SpamAssassin isn't pick this up even though it has a zipped .exe attached. My local virus scanner on my pc picks this up. I use boxtrapper to block all emails unless whitelisted, they are getting by with the from address which boxtrapper thinks is a local account.

    I have changed emails and cpanel passwords.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Have you enabled SPF and DKIM verification in the Exim Configuration Manager in WHM, or have you enabled SPF/DKIM records in your domain name's DNS zone?

    Thank you.
     
  3. Keelan

    Keelan Member

    Joined:
    Nov 16, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Via Cpanel > Authentication

    v=spf1 +a +mx +ip4:SERVERIP +ip4:OFFICEIP -all

    exim i have reject spf failures on


    Allow DKIM verification for incoming messages = off which wont let me turn on reject dkim failures.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You may want to consider enabling "Allow DKIM verification for incoming messages" so you can then reject DKIM failures.

    Thank you.
     
  5. Keelan

    Keelan Member

    Joined:
    Nov 16, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I just did this too. Hopefully that helps.

    Could i consider lowering my spam score to something like 1. Since boxtrapper should catch them anyways. Im still not quite sure why the boxtrapper is letting them through even though it isn't on the white list is this simply because it things the from domain is local?
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You can review the specific message in /var/log/exim_mainlog to determine how it's processed. EX:

    Code:
    exigrep MSGID /var/log/exim_mainlog
    Also, you should review the message header to see what the score is before lowering the SPAM score requirements.

    Thank you.
     
Loading...

Share This Page