Spool File Locked error when sending to a greylisted recipient

Status
Not open for further replies.

jagilbert

Registered
Dec 11, 2007
1
0
51
My users have encountered a problem on numerous occations where they receive an email failure notification several weeks after an email was sent. Checking the headers, what they all have in common is that the recipients' mta implements greylisting.
I understand greylisting, but I dont understand why the sending mta is sending the bounce message after such a long period. the config file specifies the following retry scheme:

* * F,2h,15m; G,16h,1h,1.5; F,4d,8h

I assume this indicates that it should try for 4 days, then give up.

This is running in a shared hosting environment, so I have limited visibility/control over the server other than via cPanel. Their support team insists that this is all the fault of the receiving mta and that there is nothing that they can do to correct it.
They have also indicated that sometimes messages get frozen and they have to flush the queue sometimes. Personally I think that the elderly bounce-backs are those frozen and flushed messages. They did run the following test for me though:
Code:
Here is an email which I've tried sending outside the 3 minute greylisting
window after first failure,

2007-12-11 17:01:20 1J2FyS-0003kY-NB <= [email protected]
U=root P=local S=388 T="Test"
2007-12-11 17:01:20 cwd=/var/spool/exim 4 args: /usr/sbin/exim -v -Mc
1J2FyS-0003kY-NB
2007-12-11 17:01:21 1J2FyS-0003kY-NB SMTP error from remote mail server after
RCPT TO:<[email protected]>: host mta1.activeinternet.com
[70.84.58.231]: 450 <[email protected]>: Recipient address rejected:
Greylisted for 3 minutes

And here is a second email within the greylisting window from first failure,

2007-12-11 17:05:45 1J2G2j-0004KK-5W <= [email protected]
U=root P=local S=388 T="Test"
2007-12-11 17:05:45 cwd=/var/spool/exim 4 args: /usr/sbin/exim -v -Mc
1J2G2j-0004KK-5W
2007-12-11 17:08:59 cwd=/root 3 args: exim -M 1J2G2j-0004KK-5W
2007-12-11 17:08:59 1J2G2j-0004KK-5W Spool file is locked (another process is
handling this message)
2007-12-11 17:10:45 1J2G2j-0004KK-5W SMTP timeout while connected to
mta1.activeinternet.com [70.86.44.83] after initial connection: Connection
timed out
2007-12-11 17:10:46 1J2G2j-0004KK-5W => [email protected] R=lookuphost
T=remote_smtp H=mta1.activeinternet.com [70.84.58.231]
2007-12-11 17:10:46 1J2G2j-0004KK-5W Completed
The thing that pops out at me is the "Spool file is locked"

Any ideas would be greatly appreciated.
 
Status
Not open for further replies.