The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SQL Disk usage error

Discussion in 'Database Discussions' started by JeremyL, Aug 22, 2003.

  1. JeremyL

    JeremyL Well-Known Member

    Joined:
    Aug 10, 2001
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    Under the SQl disk space I get this in cpanel

    /usr/bin/mysqladmin: connect to server at 'localhost' failed error: 'Access denied for user: 'root@localhost' (Using password: YES)' 4.39 Megabytes

    Any ideas on fix?

    Thanks
    Jeremy

    cPanel.net Support Ticket Number:
     
  2. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
    Try resetting the mysql root password in WHM.

    cPanel.net Support Ticket Number:
     
  3. JeremyL

    JeremyL Well-Known Member

    Joined:
    Aug 10, 2001
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    Tried that and I get

    ------------
    ERROR 1045: Access denied for user: 'root@localhost' (Using password: YES)
    /usr/bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user: 'root@localhost' (Using password: YES)'

    Password changed for root to *******
    ----------------

    And now not only is the disk space one messed up but so it the

    "Mysql databases"
    ---------
    DBI connect('mysql:localhost','root',...) failed: Access denied for user: 'root@localhost' (Using password: YES) at /usr/local/cpanel/Cpanel/Mysql.pm line 42 ERROR 1045: Access denied for user: 'root@localhost' (Using password: YES) 0 / unlimited
    -----------

    SQL Disk Usage
    ----------------
    DBI connect('mysql:localhost','root',...) failed: Access denied for user: 'root@localhost' (Using password: YES) at /usr/local/cpanel/Cpanel/Mysql.pm line 42 /usr/bin/mysqladmin: connect to server at 'localhost' failed error: 'Access denied for user: 'root@localhost' (Using password: YES)' 4.47 Megabytes
    ---------------

    I tried the stuff mentioned here
    http://forums.cpanel.net/showthread.php?s=&threadid=11302&highlight=mysql

    Still no go :(

    cPanel.net Support Ticket Number:
     
  4. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
    Something funky is going on with your machine. Try doing this:

    service mysql stop

    rm -f /var/tmp/mysql.sock
    rm -f /var/lib/mysql/mysql.sock
    rm -f /tmp/mysql.sock

    service mysql start

    ln -s /tmp/mysql.sock /var/tmp/mysql.sock
    ln -s /tmp/mysql.sock /var/lib/mysql/mysql.sock

    Now try resetting the MySQL root password and log into cPanel to see if this has resolved your issues.

    cPanel.net Support Ticket Number:
     
  5. JeremyL

    JeremyL Well-Known Member

    Joined:
    Aug 10, 2001
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    Did that exactly and no good.

    This time I used the "Reset Local MySQL password" option under the myql heading instead of the "Set mysql.. " under the main header and this is what I got

    ------------------
    Waiting for mysql to restart.....030823 12:40:16 Can't start server: Bind on TCP/IP port: Address already in use
    030823 12:40:16 Do you already have another mysqld server running on port: 3306 ?
    030823 12:40:16 Aborting

    030823 12:40:16 /usr/sbin/mysqld: Shutdown Complete

    Done
    Changing Password....ERROR 1045: Access denied for user: 'root@localhost' (Using password: YES)
    /usr/bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user: 'root@localhost' (Using password: YES)'
    Done
    Reloading Mysqld...
    Done
    -------------------

    Still no good. In cpanel I get the same errors. I can't even view mysql processes in WHM cause I get the errors.

    Any other ideas?

    cPanel.net Support Ticket Number:
     
  6. keyDet79

    keyDet79 Well-Known Member

    Joined:
    May 11, 2003
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Netherlands
    Having the same issue on one of our servers. Submitted a ticket.

    cPanel.net Support Ticket Number:
     
  7. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
    killall -9 mysql (execute that a couple of times)
    /etc/rc.d/init.d/mysql start

    cPanel.net Support Ticket Number:
     
  8. JeremyL

    JeremyL Well-Known Member

    Joined:
    Aug 10, 2001
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    Please let me know what they say on the ticket.

    Killing it doesnt work. No go ont that.

    Thanks
     
    #8 JeremyL, Aug 23, 2003
    Last edited: Aug 23, 2003
  9. keyDet79

    keyDet79 Well-Known Member

    Joined:
    May 11, 2003
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Netherlands
    They replied it was in the FAQ:

    Make sure root pass is in /root/.my.cnf

    This is usually the first root pass the box was given once cpanel is installed.

    If it still does not work, you will need to reset the mysqld root pass.

    First, stop the mysqld, usually /etc/rc.d/init.d/mysql stop
    Then stop chkservd to keep it from interfering with mysqld while you work on it with /etc/rc.d/init.d/chkservd stop
    Start up mysqld , but, without the grant tables,

    mysqld --skip-grant-tables -u mysql &

    Then change the pass..

    mysql -u root mysql
    UPDATE user SET Password=PASSWORD('new_password') WHERE user='root';
    FLUSH PRIVILEGES;

    Now you just killall -9 mysqld and start it up normally with it's safe_mysqld script..

    cPanel.net Support Ticket Number:
     
    #9 keyDet79, Aug 23, 2003
    Last edited: Aug 23, 2003
  10. JeremyL

    JeremyL Well-Known Member

    Joined:
    Aug 10, 2001
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    That fixed it thanks.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page