The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SquirrelMail and PHP 4.4.1 issues

Discussion in 'E-mail Discussions' started by SupermanInNY, Nov 11, 2005.

  1. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
    My users started to complain about SQ not functioning correctly.

    In SQ homepage:

    http://www.squirrelmail.org/

    They talk about in the very top of the page:

    SquirrelMail and PHP 4.4.1 issues
    Nov 07, 2005 by Tomas Kuliavas
    PHP developers released PHP 4.4.1 version on 2005-10-31. Security fixes introduced bug, which affects three SquirrelMail functions. If your SquirrelMail install does not use server side sorting, PHP bug can create infinite loop in message display. If you are using PHP 4.4.1, you should update it to 4.4.x-dev or apply patch.

    What I don't understand is,. do I need to apply a patch somewhere? is it patching PHP or patching SQ?

    I have many users who need to use SQ outside of the cPanel and have a directory of /public_html/mail/ and they run their own copy of SQ.
    Now,. there seem to be a problem of hangups of the software.

    Does anyone else experience this problem?

    My OS: RH9
    Apache 1.3.34
    PHP: 4.4.1

    Any suggestions? Do I need to recompile apache manually? that sounds bad, and doesn't make much sense to me. Should cPanel modify thier compile scripts?

    -Alon.
     
  2. bornonline

    bornonline Well-Known Member

    Joined:
    Nov 19, 2004
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    Hmm.. Same software versions here and I don't have any squirrel mail problems that I know of.

    Going to do some testing real quick.


    OS: RH9
    Apache 1.3.34
    PHP: 4.4.1
     
  3. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
    From Tomas Kuliavas:

    "You have courier-imap compiled with limited character set support.
    windows-1255 should be supported by courier-imap.

    SquirrelMail can issue sorting commands with iso-8859-1, iso-8859-2,
    utf-8, iso-8859-15, iso-8859-7, iso-8859-9, koi8-r, koi8-u, windows-1251,
    windows-1255, windows-1256, tis-620, gb2312, big5, euc-jp and euc-kr
    character sets. koi8-u is not supported by courier-imap, but this
    character set is used only in SquirrelMail 1.5.x. Other character sets are
    supported by courier-imap 3.0.0+, if it is compiled with --enable-unicode
    option. Recompile courier-imap or make sure that translations with
    unsupported character sets are not used."

    Can someone suggest how to re-compile courier-imap or let cPanel know of this?
    I happen to need Hebrew (windows-1255).

    the current install of Courier that was installed with the upgrade from mbox does not have the supported languge in the compile.

    -Alon.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Log it in bugzilla if it's not there already.
     
  5. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
    #5 SupermanInNY, Nov 14, 2005
    Last edited: Nov 15, 2005
  6. SageBrian

    SageBrian Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    415
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    NY/CT (US)
    cPanel Access Level:
    Root Administrator
    I had the SqMail issue also, due to the upgrade.
    (note, this is not the cpanel install of squirrel)

    I went into /config/config.php of the installed squirrelmail and changed
    Code:
    $allow_server_sort        = false;
    to 'true'

    My errors went away. It's also much faster.
     
  7. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    sorry that I missed mentioning that.
    I've done the very same thing.
    The problem that I'm having is related directly to that:

    windows-1255 encoding is not supported by the CourierIMAP, and when I do enable the Server Side Sorting, Squirrlemail shows and error msg instead of the list of emails.

    Thats why I urge folk here to VOTE for the bugzilla (you will see a VOTE option if yo log into Bugzilla) and have the developers compile and release the CourierIMAP with the additional flags.

    -Alon.
     
  8. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    one of these php versions http://snaps.php.net/ should fix these problems.
    But how to compile them !?

    May we have one of them on easyapache please ?
     
  9. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
    I think it would be easier to just compile CourierIMAP:

    " if it is compiled with --enable-unicode option. Recompile courier-imap"

    -Alon.
     
  10. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
Loading...

Share This Page