squirrelmail dependencies issue

poppyq

Well-Known Member
Jul 15, 2003
54
0
156
Portland, OR
cPanel Access Level
Root Administrator
So I've been using the latest release version (as of this it is R83), and when running upcp I get the following dependency issue with squirrelmail:

Unresolvable chain of dependencies:
squirrelmail 1.4.6-5.el3 requires php-mbstring

using RHEL3. I found one post that says to not use the system update of squirrelmail because cpanel provides their own version, but if that is the case, why doesn't cpanel automatically exclude it from updates like it does with other things like the php version? I haven't been able to find a way to resolve this issue other than excluding squirrelmail in up2date and I'm not sure if that's the proper way to do it. Any suggestions on what to do? Do I just ignore it since it doesn't seem to be causing any issues?
 

tuxdesk

Well-Known Member
Oct 1, 2005
86
0
156
check "php -m | grep mbstring". If it is not listing mbstring, recompile apache (/scripts/easyapache) with mbstring. It will solve the issue.
 

poppyq

Well-Known Member
Jul 15, 2003
54
0
156
Portland, OR
cPanel Access Level
Root Administrator
I have already compiled apache with mbstring, and running the command you gave shows it, there seems to be a difference between compiling it with mbstring and actually having the php-mbstring package installed (there is an rpm available for old versions of php). I still get the dependency error when running upcp.
 

freedog96150

Well-Known Member
Mar 25, 2005
68
0
156
Nevada, USA
poppyq said:
I have already compiled apache with mbstring, and running the command you gave shows it, there seems to be a difference between compiling it with mbstring and actually having the php-mbstring package installed (there is an rpm available for old versions of php). I still get the dependency error when running upcp.
Did this ever get resolved??? I seem to be getting dependancy issues related to mbstring. I have the option checked in easyapache, but that is not resolving the issue.
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,462
25
473
Go on, have a guess
You should not be trying to install the RHE version of squirrelmail as it isn't used by cPanel and it shouldn't have been installed with the original OS. To stop it coming up add squirrelmail* to the pkgskiplst in up2date.