The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Squirrelmail doesnt allow attachments after latest easyapache

Discussion in 'EasyApache' started by vladgur, Jul 2, 2003.

  1. vladgur

    vladgur Member

    Joined:
    Apr 18, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Yesterday when logged into whm i noticed that cpanel suggested to run easyapache to close the latest vulnerability. I did and chose all the right options as far as i can remember(php, mcrypt, etc).
    Now every time I try to attach a file to my email in Squirrelmail, I get "Could not move/copy file. File not attached". I checked with squirrelmail.org and they say it has something to do with directory permissions where the attachments are stored, but since I didnt change the permissions since I installed squirrelmail, but only recompiled apache, the problem had to lie deeper.

    I tracked the problem to this chunk of code in src/compose.php in squirrelmail home directory:

    When the above if statement returns true, the error that I mentioned is displayed. What could be happening to the uploaded file now? I verified that php.ini has not changed in a while, safe mode was on for some time already, nothing really was changed other than apache getting recompiled with some options. Maybe I didnt pick the right options to recompile it, but how do I know which ones are right? how can i tell now which options I had used?

    Any particular advice on solving the attachment problem would be appreciated

    cPanel.net Support Ticket Number:
     
  2. mmkassem

    mmkassem Well-Known Member

    Joined:
    Oct 21, 2002
    Messages:
    390
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Egypt
    Check you SQmail settings, latest easyapache does not make any problems with our sqmail.

    besides
    I remember that this was at least request was from about a week or more. Isn't this for mod_ssl upgrade?

    cPanel.net Support Ticket Number:
     
  3. goodmove

    goodmove Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    The WHM changelog mentions Squirrelmail in the latest Edge release. Is it now installed automatically?
     
  4. mmkassem

    mmkassem Well-Known Member

    Joined:
    Oct 21, 2002
    Messages:
    390
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Egypt
    yeah, it will be installed automatically.
    I believe it's in :2095/2096 .. next to neomail and horde.

    You can enable or disable it from the Tweaks settings.

    cPanel.net Support Ticket Number:
     
  5. vladgur

    vladgur Member

    Joined:
    Apr 18, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    well, i recompiled apache with different options and that seemed to have fixed things.
    Also, im not using edge releases because its a production server...

    cPanel.net Support Ticket Number:
     
  6. Olate

    Olate Active Member

    Joined:
    Aug 1, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
  7. wipl

    wipl Active Member

    Joined:
    Oct 12, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    0
    I'm facing the same problem, can you let me know the options which you chose while doing the easy apache as I did it with the requried modules but nothing seems to have changed.

    Would appreciate your reply.
     
  8. makan

    makan Active Member

    Joined:
    Nov 4, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    jakarta

Share This Page