SOLVED SSH Access & Terminal not active?

gildas

Well-Known Member
Mar 30, 2017
58
5
8
Paris
cPanel Access Level
Root Administrator
Hello,

I have a problem viewing the module: Terminal on CPANEL.
some accounts create on my server do not have access to this topic.
This can happen on a domain added to a reseller account (the main domain of the reseller account does not have this options too).
In the "Feature Manager" section the option "SSH Access & Terminal" is ticked.

Do you know where this concern might come from?

Best regards
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
Hello @gildas,

This interface only appears in cPanel if the following statements are true:
  • The account possess shell access in it's package or through WHM >> Manage Shell Access.
  • The SSH Access & Terminal feature is enabled as part of the feature list assigned to the account.
Thanks!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
Hello @gildas,

I'm glad to see the information helped. I've marked this thread as solved.

Thanks!
 

gildas

Well-Known Member
Mar 30, 2017
58
5
8
Paris
cPanel Access Level
Root Administrator
Hello,

My user has the shell disabled.
However, since the WHM if I change a client's package, this option reverts to disabled.
How to keep it active when changing packages?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
How to keep it active when changing packages?
You'll need to update the value for Shell Access via WHM >> Edit Package for the package you are upgrading/downgrading the account to if you want to ensure the shell access setting is retained.

Otherwise, you should consider creating a new package for accounts you want assigned shell access.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
all packages on which I pass my domain have Shell access enabled
I've been unable to reproduce the behavior you have reported using the steps below:

1. Created a new account with no package and with shell access disabled.
2. Browsed to WHM >> Manage Shell Access and confirmed shell access was disabled.
3. Created a package with shell access enabled.
4. Used WHM >> Upgrade/Downgrade an Account to switch the account to the package created in the previous step.
5. Confirmed that shell access is correctly enabled on the account.

Can you let me know what steps you are using that differ from the above?

Thank you.
 

gildas

Well-Known Member
Mar 30, 2017
58
5
8
Paris
cPanel Access Level
Root Administrator
Hello,

Here are the steps I take when I have this concern:

1.Create an account with a package with the Shell active
the user has the active shell in the topic: WHM >> Manage Shell Access

2.Modification of the package associated with the account create with a package with also the access Shell of active

3.Suite to this modification, in the heading "WHM >> Manage Shell Access" the user no longer has the activated shell.

When modifying the package, SHELL access is disabled.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
Hello @gildas,

I've been unsuccessful in reproducing the issue you have described. Can you open a support ticket so we can take a closer look? You can post the ticket number here and we'll update this thread with the outcome.

Thanks!