The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSH dropped or taking too long

Discussion in 'General Discussion' started by Heritz, May 25, 2007.

  1. Heritz

    Heritz Well-Known Member

    Joined:
    Aug 12, 2006
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Hello guys,

    I just bought a new monster with the Layered Tech guys. I two servers with them, but this new one has a little issue with the SSH connections.

    For example, when I connect to SSH using PuTTY, it takes toooo much time to validate the user and password.

    Using WinSCP, its always trying to reconnect or dropping the connection.

    Do you guys have any ideas about why is this happening? Its weird because it doesn't happen on my other servers!

    Thanks all!
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Although you didn't say what is your OS, some versions of glibc (notably glibc 2.1 shipped with Red Hat 6.1) can take a long time to resolve "IPv6 or IPv4" addresses from domain names. This can be worked around with by specifying AddressFamily inet option in /etc/sshd/ssh_config.

    There may be a DNS lookup problem, either at the client or server. You can use the nslookup command to check this on both client and server by looking up the other end's name and IP address. In addition, on the server look up the name returned by the client's IP-name lookup. You can disable most of the server-side lookups by setting UseDNS no in sshd_config
     
  3. Heritz

    Heritz Well-Known Member

    Joined:
    Aug 12, 2006
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    My nslookup results on my machine:
    Code:
    Microsoft Windows XP [Versión 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.
    
    C:\Documents and Settings\Danny>nslookup
    Default Server:  rs20s15.datacenter.cha.cantv.net
    Address:  200.44.32.12
    
    > hostromo.com
    Server:  rs20s15.datacenter.cha.cantv.net
    Address:  200.44.32.12
    
    Non-authoritative answer:
    Name:  hostromo.com
    Address:  72.36.237.242
    
    > 72.36.237.242
    Server:  rs20s15.datacenter.cha.cantv.net
    Address:  200.44.32.12
    
    Name:  server.hostromo.com
    Address:  72.36.237.242
    Results of the nslookup on the server:
    Code:
    root@server [~]# nslookup
    > hostromo.com
    Server:         72.36.190.2
    Address:        72.36.190.2#53
    
    Non-authoritative answer:
    Name:   hostromo.com
    Address: 72.36.237.242
    > 72.36.237.242
    Server:         72.36.190.2
    Address:        72.36.190.2#53
    
    Non-authoritative answer:
    242.237.36.72.in-addr.arpa      name = server.hostromo.com.
    
    Authoritative answers can be found from:
    > 
    
    It seems cool. And I use CentOs 4.5.
     
Loading...

Share This Page