The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSH issue

Discussion in 'General Discussion' started by Saudi-X, Jan 17, 2010.

  1. Saudi-X

    Saudi-X Registered

    Joined:
    Jan 17, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Saudi Arabia + Jeddah
    hi all
    I have VPS server running Linux OS and from time to time I need to connect to my server through SSH service and I’m using putty.
    Now when I connect to the server and after I write my password it’s asking me about the security key.

    /http://www.barakh.com/vb/uploaded/2_01263761172.png

    What I need it’s two things:

    1-How to provide the security key?
    2-Is there any way to disable the security key in the next time I need to access the SSH using root username and password only without any other requirement.
     
    #1 Saudi-X, Jan 17, 2010
    Last edited by a moderator: Jan 17, 2010
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,449
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    If you type in the word Key to the search box, top left corner or WHM in the result you'll find Manage SSH Keys.
    If you didn't enable the key someone else has, you might ask them for more details. More reading here:
    Secure Linux/UNIX access with PuTTY and OpenSSH
     
  3. Saudi-X

    Saudi-X Registered

    Joined:
    Jan 17, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Saudi Arabia + Jeddah
    hi infopro
    what I need now the way to disable the security code I need to access the SSH using root username and password only.

    I try to disable it from SSH Password Authorization but when I try to connect to the server it's give me the following error:

    PuTTY Fatal Error
    disconnected: no supported authentication methods available.
    may you please help me.
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,449
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  5. Saudi-X

    Saudi-X Registered

    Joined:
    Jan 17, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Saudi Arabia + Jeddah

    ok now I disable SSH Password Authorization Tweak
    but there was I note in your link (Remember: If passwords are disabled, your users must use SSH keys. ) is there any way to disable this feature also I don't want use SSH Keys (privet or public).

    I remember that I am able to connect to another server without SSH key or SSH Password Authorization Tweak and I need to know the steps to do that.
     
  6. Saudi-X

    Saudi-X Registered

    Joined:
    Jan 17, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Saudi Arabia + Jeddah
    any update please.:eek:
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,449
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I'm not sure I'm following this thread 100% sorry about that. I think we're both missing something here, so lets start over if we could.

    Assuming you've edited your sshd_config similar to this post suggests:
    http://forums.cpanel.net/f185/beginners-guide-securing-your-server-30159.html#post142236 Is this correct or have you not touched that file? This is important, if you've made changes to this file, what changes did you make?

    And, you've configured PuTTY correctly:
    How To Setup Putty

    ...according to the sshd_config file's settings, correct?

    I think I've given you bad Info on Disabling Password Authorization for what you want, go back in an enable it.

    Looking at your image again it says on it:
    "Using keyboard-interactive authentication"
    I think this tells us something is not setup right.

    You might want to get in touch with your host to ask for assistance in setting up your configuration properly instead of us guessing at what's needed on this server.
     
Loading...

Share This Page