The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSH Login will not work (Putty)

Discussion in 'General Discussion' started by wtgotllc, Sep 24, 2014.

  1. wtgotllc

    wtgotllc Member

    Joined:
    Aug 24, 2014
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Apopka, Florida, United States
    cPanel Access Level:
    Root Administrator
    I am have been working on this all day. Let me give you the scenario at hand. I have putty (latest version) installed on Windows 8.1.

    I have dedicated server cPanel/WHM installed 11.44.
    I have installed CSF through WHM and configured it.
    I have disabled password authentication.
    I have created key pairs in whm.
    I have changed PermitRootLogin to no.
    I added new user in terminal.
    I changed port to other than Port 22.
    I also added new user to Wheel Group in WHM.

    Thats about it and I have included some images and text files of logs and error messages.

    Please Help; I'm DYING HERE!!:confused:

    putty Fatal Error.PNG event-log-putty.PNG [/SIZE][/FONT]
     
    #1 wtgotllc, Sep 24, 2014
    Last edited by a moderator: Sep 25, 2014
  2. PascM

    PascM Member

    Joined:
    Jun 2, 2012
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    127.0.0.1
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hello,

    You seem not to have any active methods to ssh that's what the message says, you changed Permitrootlogin to no, maybe change it back to yes or ask your DC to help since you can't access those settings.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,676
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    If you are logging in as a user, make sure the public key is manually added in the "/home/$username/.ssh/authorized_keys" file.

    Thank you.
     
  4. wtgotllc

    wtgotllc Member

    Joined:
    Aug 24, 2014
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Apopka, Florida, United States
    cPanel Access Level:
    Root Administrator
    Sorry it took so long to get back with you I was able to resolve with your help
     
  5. PascM

    PascM Member

    Joined:
    Jun 2, 2012
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    127.0.0.1
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    No worries, glad you solved the problem :)
     
Loading...

Share This Page