The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ssh not ssh'ing

Discussion in 'General Discussion' started by bigj, Feb 27, 2004.

  1. bigj

    bigj Well-Known Member

    Joined:
    Aug 9, 2003
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Tucson,AZ
    When I attempt to log into a cpanel account via ssh using the supplied java interface it just hangs after authenticating.

    I got curious and tried logging in using SecureCRT and I get this message after providing the username/password:

    Authentication successful.
    Unable to verify/create directory: usr/web/web1

    That dir structure is mounted via NFS from a netapp. Could that be the problem? Thanks.

    bigj
     
  2. fgarat

    fgarat Registered

    Joined:
    Nov 30, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    same problem... any solution?

    Unable to verify/create directory: srv/clients/home

    ?????
     
  3. fgarat

    fgarat Registered

    Joined:
    Nov 30, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    soluion found

    You have to make 2 things:
    1. edit this file "/usr/local/cpanel/bin/setupvirtfs" and add the next line at the end of file
    system("mkdir","-p","/home/virtfs/$user/usr/web/web1");

    2. for every user you already have jailshell enabled create the directory
    /home/virtfs/$user/usr/web/web1


    ps: under any reason do an rm -rf /home/virtfs :mad: (yes!!, I have to restore everything!!)..
     
  4. bigj

    bigj Well-Known Member

    Joined:
    Aug 9, 2003
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Tucson,AZ

    That did the trick thanks. I'm wondering when this script gets called. In theory it should get called when the person is setup to allow for a jailed shell. By default they are all disabled in my setup. I go in and enable it and it never creates the initial /home/virtfs/$user directory structure.

    Is this script only created when the hosting account is initially created?

    bigj
     
Loading...

Share This Page