Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

ssh problem , I can't solve.

Discussion in 'General Discussion' started by 5stars, Jul 21, 2007.

  1. 5stars

    5stars Active Member

    Joined:
    Oct 10, 2006
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    156
    I recently upgraded to the latest stable version of cpanel.
    I have problems that range from just connecting with SSH on the server to changing permision for users in cpanel.


    http://www.webhosting5stars.com/problem.jpg

    I can for example change permision on the entire public html folder, but when trying to change permison on the index.html I get the fatal error above , I need to change permision for the html editor incorporated in cpanel so users can edit and save documents.
    I get the same error in the html editor when I modify something then try to save it.
    I need 777 permission, every time I try to change permission I get: [a fatal error or timeout occurred while processing this directive]

    The owner is the root, I loged in directly from WHM as root, I loged in as my client with my client usr and pass, the result has the same outcome, I get the same error.

    In the cpanel error log I get :

    /home/arraink/public_html/index.html chmod failed: Operation not permitted at cpanel.pl line 2088
    (internal death) Sat Jul 21 18:11:05 2007 [21026] error: /home/arraink/public_html/index.html chmod failed: Operation not permitted at cpanel.pl line 2088
    Carp::croak('/home/arraink/public_html/index.html chmod failed: Operation not...') called at /usr/local/cpanel/Cpanel/Fileman.pm line 850
    Cpanel::Fileman::changeperm('/home/arraink/public_html', 'index.html', 4, '', '', '', '', '', ...) called at cpanel.pl line 2088
    main::dofileman('changeperm($FORM{\'dir\'},$FORM{\'file\'},$FORM{\'ur\'},$FORM{\'...') called at cpanel.pl line 677
    main::exectag('<cpanel Fileman="changeperm($FORM{\'dir\'},$FORM{\'file\'},$FORM...') called at cpanel.pl line 3496
    main::dotag(undef) called at cpanel.pl line 3410
    main::parsehtml('GLOB(0x8ef9e38)') called at cpanel.pl line 355
    /home/arraink/public_html/index.html chmod failed: Operation not permitted at cpanel.pl line 2088


    From time to time also the SSH server simply crashes when I try to log from my desktop computer to the server using SSH, then it needs to be restarted in order to function.

    Any resolution on this from any one?
     
    #1 5stars, Jul 21, 2007
    Last edited by a moderator: Jul 21, 2007
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice