biondizzle

Registered
Mar 14, 2012
3
0
51
cPanel Access Level
Website Owner
Cannot SSH into server as root. SSH Password Authorization Tweak is Enabled and I cannot SSH with the standard root password. When I try to use root SSH keys, I get this error with PuTTY:

Server refused public-key signature despite accepting key!

The key is authorized. What setting am I missing? Just need to do this to install/manage mongoDB.
-Mike

- - - Updated - - -

Here are my specs: CENTOS 5.9 x86_64 standard – server1 WHM 11.34.1 (build 7) Load Averages: 0.08 0.05 0.06
 

jakesully

Well-Known Member
Nov 9, 2011
50
0
56
cPanel Access Level
Root Administrator
to get SSH to work is to make sure you added key into WHM SSH area and then grant premissions for key to be used or so and then you use the key file named .ppk and do you own a vps or dedi? if you dont own any of them that explains why you can't login to SSH since shared/reseller providers has no SSH enabled.
 

CitizenK

Well-Known Member
Jun 5, 2012
64
1
58
On The Road
cPanel Access Level
Root Administrator
You can resolve this issue by reseting the your sshd config file and restarting ssh. To accomplish this while locked out of your server, you can use the autofixer script for this issue. You can invoke the ssh autofixer by going to the following url. (Remember to replace example.com with your domain name or server IP)
Code:
https://example.com:2087/scripts2/doautofixer?autofix=safesshrestart
You can read more about the differnt autofixers including this one at:
The cPanel Autofixer :: The cPanel Admin
 

JaredR.

Well-Known Member
Feb 25, 2010
1,834
23
143
Houston, TX
cPanel Access Level
Root Administrator
Note that the autofixer command does not fix sshd permanently. It simply starts it with a very simple default configuration. You still need to fix the problem with the sshd configuration that prevented it from starting, or the next time it restarts, or the server reboots, you will have the same problem all over again.