The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ssh root access denied.

Discussion in 'General Discussion' started by hmos11, Mar 16, 2006.

  1. hmos11

    hmos11 Member

    Joined:
    Apr 30, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    yesterday I updated the cpanel and there wasn't any error during update and after that.
    today I can't ssh to server with root, and I get access denied error. but I can ssh with other user that have jailshell.

    password of root is correct because I can login to whm, I also change the root password from whm, but same error yet.

    datacenter work on server for 5 hours and there is no way to resolve the issue.

    there is no fault from my side, I didn't change anything or instaling new app.

    what can I do with this problem?
     
  2. adept2003

    adept2003 Well-Known Member

    Joined:
    Aug 11, 2003
    Messages:
    283
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    ~ "/(extra|special)/data"
    Couple of possible solutions:

    1. Log into WHM. Click "Security" -> "Manage Wheel Group Users". Ensure that user "root" is in the wheel group. If not, then find "root" from the scroll list and add it.

    2. If the above doesn't work, then root SSH may have been disabled. Change one of your accounts to enable normal shell (rather than just jailshell). Then add that user to the wheel group as described above (obviously replacing "root" with the user). Then log into SSH via the shell user. Once in, type "su", and enter the root password when prompted - this should now work.

    If both of the above fail, then get a server admin on the case! (e.g. Chirpy @ www.configserver.com)
     
  3. hmos11

    hmos11 Member

    Joined:
    Apr 30, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1

    At first I thanks to you adept2003 for your reply.

    the problem solved with case no. 2, I give normal shell access to one account then added it to Manage Wheel, after I loged in to ssh with that account I check the system and I saw in passwd file there is a 'n' more in shell path. :rolleyes:

    so, I changed root:x:0:0:root:/root:/binn/bash to root:x:0:0:root:/root:/bin/bash

    but I don't know the reason of this 'n' yet :confused:
     
Loading...

Share This Page