The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSH root login DENIED

Discussion in 'General Discussion' started by Lestat, Sep 10, 2005.

  1. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    Anyone that can help me solve this issue it would be great.

    OK the issue is I cannot login with my root account through ssh. I can login locally on the actual physical machine with root. I just cannot login through with ssh. I put password in and it says denied. Same thing with the users. Everything else works fine though. I can login to WHM and the cpanel for the clients. I can also ftp into all accounts as well. Running Cpanel on AS3.
     
  2. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    If you want to enable root ssh login do the following:
    Open the file /etc/ssh/sshd_config in your favorite text editor. Look for the line that says PermitRootLogin no. Change the no to a yes and then restarted the sshd service.

    If you want to keep SSH root login disabled (which many people do for security reasons), you need to add a user (or create a new user) and make that user belong to the wheel group. Once that's done, you can login to SSH as that wheel user, and then use the command su - to become the super user (root). You will be prompted for the root password when you issue that command, but again, that command only works if that user is in the wheel group.
     
  3. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    Ok first off thanks for the reply.

    Ok I have gave a user access in wheel group and did manage shell access to enable to that account. Ok the other problem is now is that machine is 30 minutes for me to check those other settings. SSH worked before and was able to login prior to this. So it should be enable already. Still no go even that user gets a denied password when trying login. Any other ideas?
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Are you using the OS vendor supplied openssh rpms or did you try to compile it yourself?

    One thing you could try is to login to the console and do:

    service sshd stop
    sshd -d -d -D


    This will run up the ssh daemon in debug mode and won't fork so you can see exactly what's happening when you attempt to connect in.
     
  5. joshtheosh

    joshtheosh Registered

    Joined:
    Jul 28, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    how do you edit the sshd_config file?

    What is the command for editing the /etc/ss/sshd_config file when I am using Putty. I can get to the file list but don;t know how to edit it.

    Thanks.
     
  6. HelloAdam

    HelloAdam Well-Known Member

    Joined:
    Nov 6, 2005
    Messages:
    145
    Likes Received:
    0
    Trophy Points:
    16
    Hey,

    Use the command

    Code:
    nano FILENAME
    
    In your case

    Code:
    nano /etc/ss/sshd_config
    
    The X's on the screen is the CTRL button on your keyboard...

    From,
    Adam
     
  7. joshtheosh

    joshtheosh Registered

    Joined:
    Jul 28, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanks HelloAdam

    Thanks HelloAdam. I appreciate it. I actually figured out to use pico and that worked.

    again thanks for the help.

    Josh
     
Loading...

Share This Page