The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

sshd starts upon reboot even though disabled in WHM Service Manager

Discussion in 'Security' started by ryodo, Mar 3, 2015.

  1. ryodo

    ryodo Member

    Joined:
    Oct 3, 2012
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Website Owner
    Hi All -

    This is new, at least since our previous PCI scan 3 months ago. The scan showed sshd was listening on port 22, even though I've unchecked it in the WHM Service Manager. Checking sshd, restarting services, then unchecking it and restarting services again turned it off. However, when I rebooted, there it was again, listening on port 22. I double-checked Service Manager and it is still unchecked.

    I'd rather not go under the hood and do something like remove it from the runlevel 3 directory. Is there a clean, WHM-friendly way to fix this?
     
  2. quizknows

    quizknows Well-Known Member

    Joined:
    Oct 20, 2009
    Messages:
    942
    Likes Received:
    57
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    Firewall off port 22 from untrusted IP's? SSHD should not cause you to fail PCI scans. I advise against disabling it unless you have a hardware KVM to use for a console in case of issues.
     
  3. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,146
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello,

    I will suggest you please do not disable SSHD services on your server, You can change your SSHD port on your serve and It will improve your server security
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,852
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  5. ryodo

    ryodo Member

    Joined:
    Oct 3, 2012
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Website Owner
    Thank you all for your suggestions. I've simply been turning off SSH as the easiest way to plug the hole, but we do use CSF and SSH login is set to require keys, so I'll take your suggestions to close port 22 and leave SSH enabled on a distant port.
     
Loading...

Share This Page