The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSHterm on non-standard port

Discussion in 'General Discussion' started by bubone2, Mar 25, 2011.

  1. bubone2

    bubone2 Member

    Joined:
    Dec 2, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    When I login to cPanel (WHM 11.28.87), on an account that has the shell enabled, I am unable to use the SSHterm. I have java on my workstation. When I launch the SSHterm window, I get the spinning Java wheel graphic and then just a blank black screen. No login prompt or anything. What can cause this? I was wondering if it might be that we are running on a non-standard SSH port.

    Thanks,
    Josh
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Have you tried another browser to rule out browser issues?
     
  3. bubone2

    bubone2 Member

    Joined:
    Dec 2, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for a quick response. That was FF 3.6.16 that I attempted before. When launching it in IE7 or Safari 5 I get the same. Google Chrome tells me that my Java 6 plugin is out of date.

    This is the error below that all browsers are showing. So, am I missing a package on the server? There is a firewall between me and the server. Actually a few while I'm at work. Might it be a port issue? If so, what port should I be concerned with? I assumed I'd be communicating to the cpanel server on just port 80.

    Josh

    Java Plug-in 1.6.0_23
    Using JRE version 1.6.0_23-b05 Java HotSpot(TM) Client VM
    User home directory = C:\Documents and Settings\username
    ----------------------------------------------------
    c: clear console window
    f: finalize objects on finalization queue
    g: garbage collect
    h: display this help message
    l: dump classloader list
    m: print memory usage
    o: trigger logging
    q: hide console
    r: reload policy configuration
    s: dump system and deployment properties
    t: dump thread list
    v: dump thread stack
    x: clear classloader cache
    0-5: set trace level to <n>
    ----------------------------------------------------


    load: class com.sshtools.sshterm.SshTermApplet not found.
    java.lang.ClassNotFoundException: com.sshtools.sshterm.SshTermApplet
    at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
    Caused by: java.io.IOException: open HTTP connection failed:http://cpanel.neues.com/frontend/x3/telnet/com/sshtools/sshterm/SshTermApplet.class
    at sun.plugin2.applet.Applet2ClassLoader.getBytes(Unknown Source)
    at sun.plugin2.applet.Applet2ClassLoader.access$000(Unknown Source)
    at sun.plugin2.applet.Applet2ClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    ... 9 more
    Exception: java.lang.ClassNotFoundException: com.sshtools.sshterm.SshTermApplet
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You'll want to make sure the port you use for SSH is opened in the firewall. You won't be using SSH on port 80, cPanel is on port 2083 and WHM 2087 both secure ports. Your work place may block those. cPanel on 2082 and WHM on 2086 are non SSL ports you may be able to use depending on server settings, but these too may be blocked.

    You mention you can get into cPanel to use the SSHterm tool in cPanel, so you must be ok there. I suppose your next stop might be to check to be sure that port for SSH is open / setup correctly.

    Not sure an out of date version of java would cause a problem, but you might like to check that you've got the latest on that workstation and remove all older versions, just to rule it out. /http://www.java.com/getjava/index.jsp
     
  5. bubone2

    bubone2 Member

    Joined:
    Dec 2, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    What you're saying makes sense. Here's some more info. I access cpanel not by the port 2082 (or 2083 for secure) but by the subdomain 'cpanel'. So http or https://cpanel.mydomain.com. This allows me to not have the port 2082/3 issue through my local firewall.

    Regarding the ssh port ... Is it the case that I'm basically tunneling through to the server via my cpanel.mydomain.com connection (port 80 or 443)? If so, then I shouldn't have to worry about SSH port all the back to my workstation right? I know that the ssh 22222 port is open and working appropriately, because I can access it directly from other locations. I can't use PuTTY directly to 22222 from my work location. So, my goal was to basically tunnel through the port 80 cpanel.mydomain.com connection. Let me know if I am misunderstanding it though.

    Thanks,
    Josh
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    SSH isn't going to tunnel through port 80. You need the port for SSH to be opened at your workplace in order to get to SSH. SSH isn't Apache and cannot be redirected through Apache--they are different protocols entirely. No matter if it is a Java client, Putty, or whatever SSH client, all are still going to use the SSH connection to the machine on the port required.
     
  7. bubone2

    bubone2 Member

    Joined:
    Dec 2, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Ok, then it's likely that I'm being blocked at my local firewall at work. Thanks.
     
  8. bubone2

    bubone2 Member

    Joined:
    Dec 2, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    What got me thinking about this again was this service that I've been using recently: SerFish. It's serving up a proxied SSH over HTTPS. It has it's limitations but it gets me through the local firewall and on to the server. There's an extremely annoying captcha authentication process for free use that pops up every minute or so. I paid a small fee to get rid of the captcha. But that got me wondering if cPanel already had this similar ability.

    Josh
     
Loading...

Share This Page