The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL active on all IP addresses, even those without certificates installed

Discussion in 'Security' started by WhiteDog, Oct 21, 2015.

  1. WhiteDog

    WhiteDog Well-Known Member

    Joined:
    Feb 19, 2008
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    Dear,

    On all our cPanel 11.52 we are faced with some odd/new behaviour.

    The setup is as follows (example):
    1.1.1.1 is the shared IP, has 20 accounts, none with a certificate installed.
    2.2.2.2 is a shared IP, has 4 accounts, all with a certificate installed (SNI).

    Accessing the websites on 2.2.2.2 via https works fine. No issues there.
    Accessing any website on 1.1.1.1 over https "responds" but off course gives a certificate mismatch. It's serving the domain over https with the server certificate. When you continue you get a "SORRY!" page.

    We also have a number of cPanel 11.48 servers that behave differently: https simply does not respond. I understand that if you install a certificate on an IP address then all sites on that IP address have SSL activated on them. But here SSL is activated on IP addresses without any certificate linked to them...

    Is this change by design or some sort of bug?
    If by design, is there a way to disable this an revert to the old behaviour?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,694
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page