The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL and cPanel not working

Discussion in 'General Discussion' started by Filmscape, May 16, 2004.

  1. Filmscape

    Filmscape Member

    Joined:
    Dec 30, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I have recently installed the latest stable release of cPanel for Red Hat Linux 3.0 Enterprise and was able to get it working OK.

    However, when I attempted to install a new SSL certificate from GeoTrust, the process looked as though it completed but would not deliver any pages within the SSL cert. WHM created the CSR and RSA Key OK, GeoTrust recognised them and produced a CRT OK, and the process in WHM seemed to install it OK. Just when attempts were made to access the cert from a https request, no pages could be delivered.

    I checked to see if this was a cPanel problem or SSL problem. I stopped the cPanel service altogether and rebooted my machine. Then I built Apache from scratch and tried accessing the SSL cert without cPanel running in the background and it worked fine. So, it would seem there is an issue between cPanel, Apache and SSL's on Red Hat Linux 3.0 ES.

    Has anyone else encountered this problem? What suggestions would you have to fix it?

    Thanks,
    Andy
     
  2. deborahgsmith

    deborahgsmith Member

    Joined:
    May 18, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    SE Michigan
    Hi Andy,

    Yes, I have experienced this as well. I am not that experienced enough to follow your workaround so I fear that I may be at a loss.

    I will watch the thread here to see if there will be a change.

    Thanks!

    Deborah
     
  3. deborahgsmith

    deborahgsmith Member

    Joined:
    May 18, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    SE Michigan
    I found an answer in another thread here on this forum.

    :)
     
Loading...

Share This Page