jhave

Member
PartnerNOC
Mar 14, 2013
8
0
51
cPanel Access Level
Root Administrator
Hello

I have tried to get it to forward the correct but for some reason it will not forvarde cpanel.domain.com to https://hostname:2083.

I have the following settings:
Always redirect two SSL: ON
Non-SSL redirect destination: HOSTNAME
SSL redirect destination: HOSTNAME

What am I doing wrong?

Regards
Jhave
 

jhave

Member
PartnerNOC
Mar 14, 2013
8
0
51
cPanel Access Level
Root Administrator
Have you also enabled Proxy subdomain creation ?
Yes its enabled.

Try domain.com/cpanel
Its works, but why the subdomains dont work correct, i got a SSL error on it

Now:

cpanel.domain.com -> https://domain.com:2083

webmail.domain.com -> https://domain.com:2096

whm.domain.com -> https://domain.com:2087

The correct metode:

cpanel.domain.com -> https://hostname:2083

webmail.domain.com -> https://hostname:2096

whm.domain.com -> https://hostname:2087

This fix the SSL error problem :)
 

Infopro

Well-Known Member
May 20, 2003
17,113
507
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
Your examples are identical.

This might be helpful:
How can I access cPanel and webmail behind a corporate proxy server? - cPanel Documentation

We have built functionality into cPanel to use cpanel.domain.com and webmail.domain.com over port 80 so that you can still access cPanel and your webmail behind a proxy server. Simply replace domain.com with the name of your website.

Note: Your web host might need to enable this functionality on the server your site is hosted on. It can be turned on or off.