The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL and Page cannot be displayed

Discussion in 'General Discussion' started by Solokron, Dec 16, 2003.

  1. Solokron

    Solokron Well-Known Member

    Joined:
    Aug 8, 2003
    Messages:
    849
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle
    cPanel Access Level:
    DataCenter Provider
    I have just restored my server. Carried user info. over etc. Now I have copied over the /usr/ssl/share directory and reinstalled the certs via fetching in WHM and installed successfully.

    When viewing a site https:// I receive the common The page cannot be displayed error.

    http is fine and 443 is open on the firewall.

    Any ideas?

    Thanks!
     
  2. Solokron

    Solokron Well-Known Member

    Joined:
    Aug 8, 2003
    Messages:
    849
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle
    cPanel Access Level:
    DataCenter Provider
    2nd time is a charm.
     
  3. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    you may need to restart the ssl

    # /usr/local/apache/bin/apachectl startssl

    If it says it running, kill the process ID# and run the command again above. You may have a stale process.
     
  4. sv1

    sv1 Well-Known Member

    Joined:
    Aug 31, 2003
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    I tried to install my cert and it seemed as if it installed correctly but now none of the secure ports seem to be working. I tried the above with still no luck. Any ideas?
     
  5. sv1

    sv1 Well-Known Member

    Joined:
    Aug 31, 2003
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    anyone?
     
  6. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Is your SSL directive in your httpd.conf file?

    <IfDefine SSL>
    <VirtualHost xx.xx.xxx.xx:443> <<< add IP address here.
    ServerAdmin user@domain.com
    DocumentRoot /home/usrname/public_html
    <IfModule mod_userdir.c>
    UserDir disabled
    UserDir enabled usrname
    </IfModule>
    User username
    Group username
    ServerName www.domain.com
    ScriptAlias /cgi-bin/ /home/username/public_html/cgi-bin/
    CustomLog /usr/local/apache/domlogs/domain.com-ssl_log "%t %{version}c %{cipher}c %{clientcert}c"
    User username
    Group username
    SSLEnable
    SSLCertificateFile /usr/share/ssl/certs/www.domain.com.crt
    SSLCertificateKeyFile /usr/share/ssl/private/www.domain.com.key
    SSLCACertificateFile /usr/share/ssl/certs/www.domain.com.cabundle
    SSLLogFile /var/log/www.domain.com
    UserDir public_html
    SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
    </VirtualHost>
    </IfDefine>

    Also, make sure port 443 is enabled, should look like the following.

    <IfDefine SSL>
    Listen 80
    #Listen 443
    </IfDefine>

    Uncomment this line ,#Listen 443
    <IfDefine SSL>
    Listen 80
    Listen 443
    </IfDefine>
    Then restart the ssl again and see if it comes up.
    If your using pico, becareful not to word wrap the ssl directive above.

    Note, I see the c" under Custom log wrapped, this needs to be on the same line at the end of CustomLog.
     
    #6 easyhoster1, Dec 27, 2003
    Last edited: Dec 27, 2003
Loading...

Share This Page