The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL being installed on www.secure.* instead of secure.*

Discussion in 'General Discussion' started by markjohnson, Jan 19, 2011.

  1. markjohnson

    markjohnson Member

    Joined:
    Apr 23, 2009
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I have installed, uninstalled and reinstalled an SSL on one account several times, with its own dedicated IP address.

    WHM tells me it has installed it successfully, but when I go to the ssl domain: secure.domain.com it says:

    Yet, it works on www.secure.domain.com, of course, with a warning that the cert is actually issued for secure.domain and not www.secure.domain.com

    Any help will be appreciated.

    Thanks
     
  2. sirdopes

    sirdopes Well-Known Member
    PartnerNOC

    Joined:
    Sep 25, 2007
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Do both www.secure.domain.com and secure.domain.com resolve to the same ip address? Generally, the error that you are seeing is because apache is not listening on port 443 for that ip address.
     
  3. markjohnson

    markjohnson Member

    Joined:
    Apr 23, 2009
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    according to ping, www.secure.domain.com is pointing to an IP address I do not recognise (I have complete control over its DNS), while secure.domain.com is pinging the right IP address.

    What's more, suddenly, it's working fine!
     
Loading...

Share This Page