Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SSL Broken- End of my rope

Discussion in 'General Discussion' started by capnqwest, Oct 1, 2006.

  1. capnqwest

    capnqwest Member

    Joined:
    Jun 19, 2003
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Redmond, WA
    Ok, I've searched all over the forum for most of this day without success. I tried to install a .crt and .key for a domain with a dedicated IP and it broke https for all of my domains.

    I tried killing stunnel and then restarting cpanel with no luck. I added my version of stunnel to the stopstunnel script in /usr/local/cpanel/etc/init, ran that script and then restarted cpanel. But https stil won't work for any of my domains.

    Code:
    root@lt2 [/usr/local/cpanel/etc/init]# less stopstunnel 
    #!/usr/bin/perl
    
    killstunnel();
    sub killstunnel {
            system("/scripts/ckillall -9 stunnel");
            system("/scripts/ckillall -9 stunnel-3.22local");
            system("/scripts/ckillall -9 stunnel-4.00local");
            system("/scripts/ckillall -9 stunnel-4.02local");
            system("/scripts/ckillall -9 stunnel-4.04local");
            system("/scripts/ckillall -9 stunnel-4.05local");
    }
    Any suggestions? I have some very angry customers.

    Thanks.
     
    #1 capnqwest, Oct 1, 2006
    Last edited: Oct 1, 2006
  2. capnqwest

    capnqwest Member

    Joined:
    Jun 19, 2003
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Redmond, WA
    The fix for this was to comment out the CAbundles for the domains and then restart httpd with ssl via /scripts/restartsrv_httpd.

    Never had a problem with that until today but that worked. If you set up a new domain, only put in the .crt and .key and you shouldn't have any problems. I hope this helps someone.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice