The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL Cert on WHM Root Login Page?

Discussion in 'Security' started by ChrisHockey, Oct 29, 2012.

  1. ChrisHockey

    ChrisHockey Registered

    Joined:
    Oct 29, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi All,

    I have a vps license and installed the cpanel/whm on my linode. Once I had it installed, the final step said to login to whm at my IP address (96.xxx.xxx.6:2087). My hostname is vps.theXXXXXXXXX.net. I would have assumed that I would login to whm (as root) at vps.theXXXXXXXXX.net, rather than ipaddy:2087.

    Is that the way it is suppose to work? Is there a way to have it as vps.theXXXXXXXXX.net?

    Also, when I access via the ip, it gives me a security warning and asks if I want to proceed. I want to have the WHM as ssl. How do I put a SSL on the site if I have to login via the ipaddy?

    Thanks!

    Chris
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You'll login with the IP and ignore that browser warning for now. You have to set the host name first. Once the host name is setup properly you can use it, and accept the Cert into your browser, which will get rid of that error about the Cert.
     
  3. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    I just ordered a new centos server and everytime I go to the domain name whatever.something.com:2086 it gives me the cert warning and then forces me to the 2087. If i install the cert it claims its installed but next time I go back in the same thing happens.

    I alays see "The security token is missing from your request" this is with windows 7 64 bit on IE 9.


    The host name is set correctly. Any idea what else could be wrong ?
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You might check your Redirection settings in WHM. As for the Cert, try this:

    1. Run IE as an administrator (Right-click desktop icon if you have one, or from Start menu)
    2. Visit the site whatever.something.com:2087 or for your users who access only cPanel/webmail whatever.something.com:2083
    3. Click through the certificate error
    4. Click the “Certificate Error” button in the address bar.
    5. Click View Certificate
    6. Click Install Certificate
    7. Unlike XP which stored these automatically for you, you must click the “Place all certificates in the following store” radio button, and choose the “Trusted Root Certification Authorities” store. If you don’t do this, the certificate goes in your personal store, and it isn’t trusted properly.

    HTH!
     
Loading...

Share This Page