The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL Certificate Error

Discussion in 'Security' started by manaberry, Jun 21, 2016.

Tags:
  1. manaberry

    manaberry Registered

    Joined:
    Jun 21, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Netherlands
    cPanel Access Level:
    Root Administrator
    Hello,

    I have a dedicated server. I have one site hosted. I have a wild card SSL, and when I try to go from:

    http://domain.xx/cpanel, it brings me to the https://host.domain.xx:2083/, which is what I originally wanted.

    However, if I type in: https://domain.xx:2083/, then it tells me:

    Code:
    Your connection is not private
    Attackers might be trying to steal your information from [B]example.com[/B] (for example, passwords, messages, or credit cards).
    
    NET::ERR_CERT_COMMON_NAME_INVALID
    
    Why is it doing this?

    I clicked the lock sign, and found this:

    - Removed Please Attach Images to Your Posts -
     
    #1 manaberry, Jun 21, 2016
    Last edited by a moderator: Jun 21, 2016
  2. Ameya Barwe

    Ameya Barwe Well-Known Member

    Joined:
    Jan 1, 2016
    Messages:
    49
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Nashik
    cPanel Access Level:
    Root Administrator
    Hi,

    You can change the redirection settings in the WHM > Tweak Settings under the "Redirection" tab in:

    WHM Home > Server Configuration > Tweak Settings

    Use "Origin Domain Name" instead of "Hostname" or "SSL Certificate Name".
     
  3. manaberry

    manaberry Registered

    Joined:
    Jun 21, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Netherlands
    cPanel Access Level:
    Root Administrator
    Hello,

    I have tried doing that. Same error... if I go from: https://domain.xx:2083, it brings me to this page:

    Your connection is not private
    Attackers might be trying to steal your information from domain.xx (for example, passwords, messages, or credit cards).

    NET::ERR_CERT_COMMON_NAME_INVALID


    However, if I just go from: domain.xx:2083, then I am actually redirected to: host.domain.xx:2083. If I add an https, and use the port (2083 or 2087), then it shows the error I showed above.

    Edit: my first post did not show the image properly, and I can't even edit the post (says I'm a spammer .-.), so here is the image when I investigated by clicking the lock icon on my browser's URL bar:

    i.imgur.com/s0uzLxG.png
    Whenever I use: https://domain.xx:2083, cPanel seems to issue its own certificate. However, if I use: http://domain.xx:2083, then my wildcard SSL certificate is used.

    Any reason why?

    Edit 2: Here are my settings for the redirection tab. These are my original settings (note I tried all of these combinations).

    i.imgur.com/kO8b1g0.png


    And yes, I did clear my cache, and even restarted my server, after each combination, but no luck.
     
    #3 manaberry, Jun 21, 2016
    Last edited by a moderator: Jun 21, 2016
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,789
    Likes Received:
    665
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Redirection does not apply when using the port numbers in the URL. Thus, it's detecting a certificate name that's different than the domain name used in the URL. You can vote for the existing feature request that's open to allow SSL certificates on a per-domain basis for services such as cPanel/WHM at:

    SSL certificate per domain on all services

    Thank you.
     
Loading...

Share This Page