Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL Certificate Issue - Cannot Access Subdomain

Discussion in 'Security' started by Locky, Sep 28, 2017.

Tags:
  1. Locky

    Locky Registered

    Joined:
    Sep 4, 2017
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Auckland
    cPanel Access Level:
    Root Administrator
    I'm having trouble with a recently installed SSL certificate. This is a renewal of a certificate that had been working for the previous 12 months.

    When I go to Install an SSL Certificate on a Domain and load up the certificate WHM tells me that the certificate is for the following domains and 2 subdomains (this is correct):

    Domains:
    mydomain.com
    accounts.mydomain.com
    spock.mydomain.com
    Issuer: COMODO CA Limited
    This SSL certificate was already installed.

    But after installing it is apparently on available on the primary domain, not subdomains.

    The SSL website is now active and accessible via HTTPS on this domain:
    mydomain.com
    The SSL website is also accessible via this domain, but the certificate does not support it. Web browsers will show a warning when accessing this domain via HTTPS:
    mail.mydomain.com
    The SSL certificate also supports these domains, but these domains do not refer to the SSL website mentioned above:
    accounts.mydomain.com
    spock.mydomain.com

    Further to this, after installing this certificate accounts.mydomain.com is no longer accessible - I get a "SORRY" page at cgi-sys/defaultwebpage.cgi, saying the server is misconfigured or dns changed :(

    Trawling through the AutoSSL logs I can see that cpanel tried to obtain a certificate automatically for accounts.mydomain.com - even though I had purchased a certificate for this. I have since disabled autoSSL for this particular domain - but while it was activated AutoSSL logged the following:

    The website “accounts.mydomain.com”, owned by “mydomain”, has no SSL certificate. AutoSSL will attempt to obtain a new certificate and install it.

    Very strange as the certificate purchased and installed should cover this domain.

    Additional to all of this, when I look at Manage SSL Hosts there is no entry anywhere for accounts.mydomain.com.

    Also in Manage SSL Hosts my primary mydomain.com is listed with a green secure padlock symbol, but www.mydomain.com is listed under it with a red open padlock. It seems really messed up and even the www is not secured on the primary domain :(

    I wish I could just remove everything and reinstall fresh - it worked when I set this up a couple of years ago and when I renewed certificate a year ago. It's only this renewal and install that is giving issues.

    Any help is much appreciated.

    Cheers,

    Locky
     
    #1 Locky, Sep 28, 2017
    Last edited by a moderator: Sep 29, 2017
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,424
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look at the account?

    Thank you.
     
Loading...

Share This Page