SSL certificate only for subdomains. Main domain on another hosting.

Operating System & Version
linux - Kernel: 4.18.0-348.12.2.lve.el8.x86_64
cPanel & WHM Version
cPanel 102.0 (build 15)

NETROPOL

Registered
May 26, 2022
2
0
1
Spain
cPanel Access Level
Reseller Owner
Hello!

Let's see if you can help me, since my hosting provider does not offer me many solutions about this.

I have a WordPress multisite hosted on a cPanel account on a shared hosting.
The main multisite domain is hosted on another server and in my cPanel I only use the multisite websites that are in subdomains.
At the moment, I have created two subdomains, but it only allows me to install Let's Encrypt on one of them. If I add it to a subdomain, it is removed from the other one and so on.

First, I would like to know if what I am trying to do is possible: To have the main domain on another hosting and the subdomains on my cPanel and all of them with SSL certificate Let's Encrypt.
If this is not possible, how can I activate the SSL certificates for the rest of the subdomains? should I buy a paid certificate and assign it to each subdomain or is there a better way to do it?

Thank you very much for your help!
Daniel
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
10,360
1,632
363
cPanel Access Level
Root Administrator
Hey there!

First, I would like to know if what I am trying to do is possible: To have the main domain on another hosting and the subdomains on my cPanel and all of them with SSL certificate Let's Encrypt.
I don't see why this wouldn't work. As long as the DNS for the subdomains is pointed to the cPanel machine where AutoSSL is running, I would expect the certificates to be issued. We may need to examine your specific configuration to get you a more official answer if things aren't working how you expect, so if you have root access to the machine feel free to submit a ticket to our support team.
 

NETROPOL

Registered
May 26, 2022
2
0
1
Spain
cPanel Access Level
Reseller Owner
Thanks for your reply cPRex

The DNS for each subdomain point to my Cpanel properly.
Attached is a screenshot. If I click reinstall on the second domain, the certificate is installed correctly, but then the first domain loses the installed status.
I do not have root access. It is a shared hosting and I access Cpanel directly.

So you confirm that what I am trying to do should be able to be done without any problems, is that right?
 

Attachments