SSL Certificate Prompts

Rockforduk

Well-Known Member
May 5, 2016
45
4
58
London
cPanel Access Level
Root Administrator
Hi Everyone,
I use CloudFlare SSL certificates on my websites and recently a noticed a strange problem with emails. Some websites when you get prompted to accept the ssl certificate works fine, but others don't and keep popping up again everytime to restart the email client? The certificates are all in date but they just don't seem to be registering with the email client. This is happening with Thunderbird & Outlook, any suggestions as to why?

Thanks

Rockforduk
 

GOT

Get Proactive!
PartnerNOC
Apr 8, 2003
1,755
316
363
Chesapeake, VA
cPanel Access Level
DataCenter Provider
I would make sure that you are not using domain.com as the incoming and outgoing mail server. You should be able to use mail.domain.com for that and not get a certificate warning at all assuming that points directly to your server and you have autossl running
 

24x7server

Well-Known Member
Apr 17, 2013
1,911
97
78
India
cPanel Access Level
Root Administrator
Twitter
Some websites when you get prompted to accept the ssl certificate works fine, but others don't and keep popping up again everytime to restart the email client?
This may be related to the the settings you use on your email client? Do you use domain name in the mail client? Do you get the same certificate issue on the webmail too?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,272
313
Houston
It could also be related specifically to the fact that CloudFlare doesn't usually cover subdomains by default, especially the mail subdomain. You may want to turn their SSL service off for the mail. subdomains and utilize AutoSSL for those or serve them directly from cPanel rather than proxy through CloudFlare