The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL creating not working !! [Help Please]

Discussion in 'General Discussion' started by techdevil, Jul 13, 2011.

  1. techdevil

    techdevil Registered

    Joined:
    Jul 13, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hello..
    i am trying to create SSL for my domain, and i am unable to setup.

    getting only a single error..

    which is as followed-

    [​IMG]

    see in that image i cant see-

    "Activate SSL on your website (HTTPS) which must be as-

    [​IMG]

    can you please help me why is it so ??? waiting for reply......
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    You would need to contact your hosting provider if this option is not available in your cPanel interface. They would have disabled the capability and you would likely have to ask them to install the SSL for you instead.
     
  3. techdevil

    techdevil Registered

    Joined:
    Jul 13, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    well what if i own dedicated server.. :P and i am self root.


    Then how can i fix it ? also, is this problem arrising due to Non-Dedicated IP account ?
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please note that you can install SSL certificates in WHM rather than in cPanel when the root user in WHM > SSL/TLS area.

    Next, you'll need to ensure this is enabled in WHM > Packages > Feature Manager area:

    Finally, you'll have to ensure the account has a dedicated IP. If it doesn't, then you are correct that the option to activate an SSL will not be visible for the cPanel account.
     
  5. techdevil

    techdevil Registered

    Joined:
    Jul 13, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    ok Thanks i got issue. its due to Dedicated IP i think. well i will install Dedicated IP and then let you know about its resolved or not.
     
Loading...

Share This Page