The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL error after migrating server

Discussion in 'General Discussion' started by allzhat, Dec 28, 2011.

  1. allzhat

    allzhat Registered

    Joined:
    Dec 28, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Ok, I think this is a riddiculous question

    I have exploring the forum and I have no idea how to solve the problem :
    - My company have a client that SSL's error here the case:
    "sometimes ago, my company decided tomove entire accountto a new server. One account there have SSL certificates from GeoTrust, the client is using static IP for the installation certificate.when transfering account,we do not give static IP because IP APNIC difficult to obtain. currently static IP has been given,we have been guiding the client to create a new CSR is then generated a new certificate.The certificate has been generated perfectly, but I'm still having problems"certificateerror" in it"

    here the URL:
    http://bmtaliya.com ---> working perfectly
    https://bmtaliya.com ---> SSL connection error
    bmtaliya.com:443 ---> moving page to cgi-sys/movingpage.php

    is there any setting that I doesn't applied yet or.... please help

    ps: * I'm sorry for my bad english
     
    #1 allzhat, Dec 28, 2011
    Last edited by a moderator: Dec 29, 2011
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You will need to install the updated CRT file now that a new CSR/Key has been generated. You can obtain this from your SSL issuer, and then install it via:

    "WHM >> SSL/TLS >> Install a SSL Certificate and Setup the Domain"

    Thank you.
     
  3. allzhat

    allzhat Registered

    Joined:
    Dec 28, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    wow thanks for the answer, I'll follow the instruction immediately

    but I'm curious, what if I terminate the account and move it again from the old server, but now it'll have a dedicate IP address attached on it (I do the same thing but I'll done it upside down)... just curious, otherwise I'll follow your step

    thank you very much Mike :)
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  5. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If you have a dedicated IP address on the old and the new machine when you re-transfer it (basically, checking dedicated IP box in the WHM > Transfers > Copy multiple accounts/packages from another server area), it should copy over the old certificate and install the SSL properly on the account. The main reason an SSL doesn't transfer or doesn't install on an account transfer is due to not using a dedicated IP on the destination machine during the transfer process. Without a dedicated IP, the account cannot have an installed SSL certificate.
     
  6. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    526
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Earth
    I just transferred a client form one of my old servers to a new one. The SSL cert is throwing errors on the new box. In FireFox when I display the Technical Details I get this...

    secure.clientdomain.com uses an invalid security certificate.
    The certificate is only valid for hostname.myserver.com
    (Error code: ssl_error_bad_cert_domain)


    What am i doing wrong?
     
  7. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Does the new server have a different hostname? If so, that's why you are receiving the message, since the certificate is only valid for the old hostname (hostname.myserver.com) from the old machine.

    Otherwise, the SSL certificate for that domain may not have properly copied over if the hostname.myserver.com is the new server's hostname for the valid certificate.
     
Loading...

Share This Page