The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL Error

Discussion in 'General Discussion' started by grayloon, Apr 16, 2009.

  1. grayloon

    grayloon Well-Known Member

    Joined:
    Oct 31, 2007
    Messages:
    98
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Evansville, IN
    cPanel Access Level:
    Root Administrator
    Twitter:
    The HTTPS address for my primary IP address is throwing an error in Firefox:
    I'm getting this on both my development and production servers. Can anyone help me troubleshoot and resolve this issue?
     
  2. arunsv84

    arunsv84 Well-Known Member

    Joined:
    Oct 20, 2008
    Messages:
    373
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    127.0.0.1
    cPanel Access Level:
    Root Administrator
    This usually indicates that the remote peer system has a flawed implementation of SSL and also violating the SSL specification.

    * Ensure that port 443 is open and enabled on your server. This is the standard port for https communications.

    * If SSL is using a non-standard port then FireFox 3 can sometimes give this error. Ensure SSL is running on port 443.

    * If using Apache2 check that you are using port 443 for SSL.

    * Make sure you do not have more than one SSL certificate sharing the same IP. Please ensure that all SSL certificates utilise their own dedicated IP.

    * If using Apache2 check your vhost config. Some users have reported changing <VirtualHost> to _default_ resolved the error.

    Refer the following link too...

    http://bug.gd/search/details/69648/ssl_error_rx_record_too_long

    Hope this helps.

    :)
     
    #2 arunsv84, Apr 16, 2009
    Last edited: Apr 16, 2009
  3. grindlay

    grindlay Active Member

    Joined:
    Dec 8, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Edinburgh, Scotland
    cPanel Access Level:
    Root Administrator
    Another cause to add to the list is DNS propagation.
    I recently moved a domain to a new (unshared) IP so that I could install a Cert.
    I got this error, but when I set my preferred DNS to the IP of the domain, it goes away. Check by pinging the domain you've installed the Cert on - it should resolve to the correct IP.
    G
     
  4. MDIWade

    MDIWade Registered

    Joined:
    May 8, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    OK the port 443 seems to be an issue, but I don't want to go digging and experimenting on a customer's whm and the support area of cpanel is short in this area.

    How does one go about opening port 443 and making this work?

    It seems to me when you choose the purchase and install option it should make sure that it functions!

    The SSL merchant that was recommended by cpanel supposedly has a dedicated line for cpanel customers, yet they say they cannot help, sounds pretty dedicated to me :confused:
     
Loading...

Share This Page