SSL Generation & Installation

thevsp

Member
Nov 5, 2001
21
0
301
As I attempt to establish an SSL certificate for my site, it appears that the correct files are created however when I paste the contents of \".key\" and \".crt\" then press \"Do It\"... nothing happens.

I reviewed some items posted here and tried it with my sites information but the httpd service failed to restart so I had to back out the things I did manually to get the service to start.

If I create a sub-domain called \"secure\", do the forms, etc need to be within this sub-domain directory?

Any clues on how to get this working within WHM?

Thanks Much! ;)

[Edited on 11/20/01 by thevsp]
 

rpmws

Well-Known Member
Aug 14, 2001
1,822
8
318
back woods of NC, USA
certs need to be installed on dedicated IP accounts. Basically you you could then call any page from that site using https://thatdomain.com/anyfile

I have seen problems with WHM ..but what I do is verify the certs are there and then restart apache and I get SSL. Works for me every time. I have over 20 Certs on one box.
 

neon

Registered
Nov 21, 2001
3
0
301
[quote:f61ffa3806]As I attempt to establish an SSL certificate for my site, it appears that the correct files are created however when I paste the contents of \".key\" and \".crt\" then press \"Do It\"... nothing happens.
[Edited on 11/20/01 by thevsp] [/quote:f61ffa3806]

are you doing this on internet explorer, i faced same problem, when i click do it nothing happens (absolutly nothing) then i tried it through netscape and it gone fine.

strangee ..... but it worked.
 

thevsp

Member
Nov 5, 2001
21
0
301
[quote:c9a4167f15]
are you doing this on internet explorer, i faced same problem, when i click do it nothing happens (absolutly nothing) then i tried it through netscape and it gone fine.

strangee ..... but it worked. [/quote:c9a4167f15]

I am using IE 6 under XP so that may be the issue as I have verified that the .key and .crt files were createad. Any particular version of netscape? With netscape, any modifications to the httpd.conf necessary?

Thanks much! :)
 

neon

Registered
Nov 21, 2001
3
0
301
try using opera its best and fast. whm also works fine with this. download size is also very small. cheers.
 

thevsp

Member
Nov 5, 2001
21
0
301
[quote:002a4b14e2]
are you doing this on internet explorer, i faced same problem, when i click do it nothing happens (absolutly nothing) then i tried it through netscape and it gone fine.

strangee ..... but it worked. [/quote:002a4b14e2]

Tried it with netscape 6.2 and received the following response in WHM:

Attempting to verify your certificate.....
13386 : error : 0906D06C : PEM routines : PEM_read_bio:no start line : pem_lib.c:662:Expecting: CERTIFICATE
Sorry the Certificate has a problem
/usr/share/ssl/certs/thevsp.com.crt.test: unable to load certificate file

???


[Edited on 11/21/01 by thevsp]
 

thevsp

Member
Nov 5, 2001
21
0
301
[quote:04487af615]try using opera its best and fast. whm also works fine with this. download size is also very small. cheers. [/quote:04487af615]

Opera? where can this be d/l\'d from?
 

moronhead

Well-Known Member
Aug 12, 2001
706
0
316
[quote:42d066f11b] try using opera its best and fast. whm also works fine with this. download size is also very small. cheers. [/quote:42d066f11b] Good advice if you don\'t mind watching the banner adverts as you\'re surfing. ;)