The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL instalation error

Discussion in 'General Discussion' started by duranduran, Dec 14, 2008.

  1. duranduran

    duranduran Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    When a try to install the SSL i get this error:

    Sorry, you must have a dedicated ip to use this feature for the user: cluster0! If you are intending to install a shared certificate you must use the username "nobody" for security and bandwidth reporting reasons.
    SSL Install aborted due to error.


    I have a dedicated IP. I will try to share this SSL to all domains in this server.
     
  2. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Same error here and its on a dedicated IP already
     
  3. piecenet

    piecenet Registered

    Joined:
    Dec 20, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Having the same problem due to using a shared certificate. Get the error message:

    The specified domain is not configured on the system. If you are intending to install a shared certificate you must use the username "nobody" for security and bandwidth reporting reasons.
    SSL Install aborted due to error.​

    So, I try again and change username to nobody and same message.
     
  4. duranduran

    duranduran Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    The problem continues...

    Now if i have a SSL certificate instaled fo a domain and i try to "share" thsi certificate in the server (for all domains) dont work.

    In "Manage SSL Hosts" i share a instaled certificate, and when i try to access usin https://cluster02server.com/~tudoporm/ - dont work (the certificate is installed in https://node.cluster02server.com and works fine.

    I miss something ?
     
  5. lehels

    lehels Well-Known Member

    Joined:
    Jul 10, 2006
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    Same here,
    It's a newly issued certificate, and the domain has a dedicated IP.


    Installing SSL Certificate
    Sorry, you must have a dedicated ip to use this feature for the user: username! If you are intending to install a shared certificate you must use the username "nobody" for security and bandwidth reporting reasons.
    SSL Install aborted due to error.

    Anyone could give a hint?

    Thanks,
    Lehel
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Is this SSL certificate just for the main domain on the cPanel account? If not, please elaborate. Is this a shared SSL certificate?
     
  7. lehels

    lehels Well-Known Member

    Joined:
    Jul 10, 2006
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    The SSL Certificate it is just for the main domain issued for www.adomain.com, all the fields are autocompleting with the correct data from the cPanel account. It is not a shared SSL Certificate to use with /nobody/.

    Thanks,
    Lehel
     
  8. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Hmm, in that case feel welcome to have our technical analysts take a look at things for you so we can figure out what's causing this issue: http://tickets.cPanel.net/submit
     
  9. compunet2

    compunet2 Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    310
    Likes Received:
    0
    Trophy Points:
    16
    Same error here... Ticket number: 423001
     
  10. lehels

    lehels Well-Known Member

    Joined:
    Jul 10, 2006
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    Hello, please announce if anything you`ll find out.
    Thanks,
    Lehel
     
  11. compunet2

    compunet2 Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    310
    Likes Received:
    0
    Trophy Points:
    16
    The issue was that in /var/cpanel/mainips there were two old files in there that had the IP listed which is why I could not install the certificate. cPanel removed those two files and was able to install the certificate successfully.

    The odd part was, the old files could not be found anywhere in WHM.
     
    #11 compunet2, May 7, 2009
    Last edited: May 7, 2009
  12. dhost

    dhost Active Member

    Joined:
    Nov 29, 2002
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Any other possible solutions. I'm having the same problem and don't have any old files in that directory or on the server. The SSL is for mydomain.com and the shared SSL is for server.mydomain.com (user nobody). The server SSL installed fine and I though that it might be causing the problem for mydomain.com. So, I uninstalled the shared server SSL and confirmed that ips are assigned correctly but still get the error.

    Any other suggestions would be appreciated.
     
  13. ezak

    ezak Member

    Joined:
    Aug 20, 2007
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    same error here

    Sorry, you must have a dedicated ip to use this feature for the user: user! If you are intending to install a shared certificate you must use the username "nobody" for security and bandwidth reporting reasons.

    SSL Install aborted due to error.

    any idea how to fix this problem ?
     
  14. mrdinkle

    mrdinkle Registered

    Joined:
    Jun 15, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Same problem here, I was renewing a cert when it happened.

    If I do change the user to nobody, it makes the SSL useless as I get permissions errors on the site that uses the cert (for session folder etc).

    Please post a fix, this is quite obviously something that several people are experiencing.
     
  15. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Indeed, but often there are several possible causes for seemingly identical issues.

    To anyone experiencing this issue: if you can have our technical analysts login to your server, this will help us identify what is causing this issue on these servers. If our technical analysts notice a common deficiency, these support requests will help expedite a relevant fix.
     
Loading...

Share This Page