Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL issue with domain name

Discussion in 'Security' started by Leila, Aug 11, 2017.

  1. Leila

    Leila Member

    Joined:
    Aug 11, 2017
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Croatia
    cPanel Access Level:
    Website Owner
    Hi I have similar problem. I will explain everything from start. I'm not tech savy so I don't know how to preform solution from previos posts.

    Here it goes:

    Yesterday I have opend new Cloudflare account so I can ad free SSL certificate to my main domain example.com and subdomain worldofbricktoys.example.com .

    I have followed steps and changed my Name servers at Godaddy. My host is Hostgator.

    I have added my subdomain to Cloudflare in this way:

    Type A
    Record name: worldofbricktoys.example.com
    Value: 192.254.xxx.xx (my main domain IP)
    Automatic
    Cloud is orange color.

    Also I have added in Page Rules

    http://example.com/*
    Always use https

    http://worldofbricktoys.example.com/*
    Always use https

    My main domain example.com works fine for others and my subdomain worldofbricktoys.example.com works fine for others but for me it is problem.

    I use Android 5.1 tablet ( no 3G just home wifi) and two PCs one Linux Ubuntu and one Windows 7. On every device on Chrome, Firefox, Safari, Opera and IE my both domains are not working right. And that is just for me.

    I see my main domain example.com but in Chrome, IE, Firefox there is red bar not safe and other people see it normal green bar with lock.

    I don't see my subdomain worldofbricktoys.example.com at all. I get 404 page not found error with Hostgator display.

    I have contacted Hostgator Tech Suport and they see my subdomain worldofbricktoys.example.com normal with green bar lock. And they looked at cPanel and everything is OK.

    They also tell me to try to see my subdomain in kproxy and there I see it normal with green bar lock and I can log into my WP dashboard. So through kproxy I can manage my subdomain just fine WP dashboard login works but in Chrome, Firefox, IE, Safari and Opera NO!
    I get 404 Page not found error. And that is just on my side. Everybody else see my sites just fine.

    I have conntacted Cloudflare Community Suport they also see my both sites just fine with green bars lock.

    And now I'm stuck. I'm hitting the wall and I don't know what to do!

    I really need help. Thank you!

    I forgot to say that I have cleared cache/history more then 10 times. In Chrome and with CCleaner.

    I have run Chrome Tools scanning for malware and everything is OK.

    I have sign out of Chrome I try to cache my subdomain but 404 Page not found error is still there.

    I habe reinstalled Chrome on Android tablet but no luck. Again 404 Page not found error on subdomain.

    And I have tried in incognito mode also but 404 is still there.
    - Removed -
     
    #1 Leila, Aug 11, 2017
    Last edited by a moderator: Aug 11, 2017
  2. Leila

    Leila Member

    Joined:
    Aug 11, 2017
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Croatia
    cPanel Access Level:
    Website Owner
    I have found one more problem when I open my subdomain and go to my WP dashboard and choose Costumize, since I want to remove from footer something. When the page loads it shows my WP dashboard but in background is 404 Page not found error.
     
    #2 Leila, Aug 11, 2017
    Last edited by a moderator: Aug 11, 2017
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,165
    Likes Received:
    1,371
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hi @Leila,

    Could you point your hosting provider to this thread and have them verify if the recent EasyApache 4 updates are applied to the affected system?

    Thank you.
     
    #3 cPanelMichael, Aug 11, 2017
    Last edited: Aug 14, 2017
  4. Leila

    Leila Member

    Joined:
    Aug 11, 2017
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Croatia
    cPanel Access Level:
    Website Owner
    I will conntact them and then I will update you about their info.
     
  5. Leila

    Leila Member

    Joined:
    Aug 11, 2017
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Croatia
    cPanel Access Level:
    Website Owner
    So I have conntacted the Hostgator Tech support and the short answer is this from their side they see my site just fine, everything works OK. I have pointed them to this tread and they said this;

    Since I'm on shared hosting, they do not use on shared hosting Easy Apache4.

    Their answer is "For our shared boxes we make updates and system changes manually through our Level 2 admins. Right now easy apache 4 is disabled on the shared boxes since they interfere with our custom scripts and tools that we have right now while our devs work on updating them to work with the new easy apache 4."

    Also they don't see server problem and they pointed taht the problem is in my internet provider and/or my PC.

    So what now?
     
  6. Leila

    Leila Member

    Joined:
    Aug 11, 2017
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Croatia
    cPanel Access Level:
    Website Owner
    So I have discovered what is giving me this "404 Page not found error This page odes not exist" . It is plugin Really simple SSL and activated SSL certificate.

    If I deactivate this plugin my subdomain is ok for me, I can log into WP dashboard and so on but normally there is no green bar and I don't have SSL certificate active on my subdomain.

    If I activate plugin Really simple SSL and activate SSL then I get 404 "Page not found error This page odes not exist".

    So what do you recommend? Any other plugin for activating SSL or to dismiss Cloudflare altogether and change back name servers to hostgator?

    I want to correct myself when I deactivate Really simple SSL plugin I see my subdomain normal, no 404 error but I can't login to my WP dashboard.

    When I try it gives me 404 error if I type worldofbricktoys.exaple.com/wp-admin
     
    #6 Leila, Aug 12, 2017
    Last edited by a moderator: Aug 12, 2017
  7. Leila

    Leila Member

    Joined:
    Aug 11, 2017
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Croatia
    cPanel Access Level:
    Website Owner
    I know that Moderator will "kill me" when he sees this posts :) , but you are my only one that I can talk abou this problem.

    I have cleared the cache and now I can login to my WP dashboard login when Really simple SSL plugin is deactivated.
     
  8. Leila

    Leila Member

    Joined:
    Aug 11, 2017
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Croatia
    cPanel Access Level:
    Website Owner
    So to update you:

    Yesterday I was able to login to my subdomain WP dashboard. But today no. I have contacted Hostgator tech support and they also could not login to my subdomain WP dashboard at all. Even after disconnecting external plugins. So they ask me to remove my subdomain from Cloudflare and I did it. After that they did get DNS error and my subdomain went to drain. So I have erased my subdomain from cPanel and I make new subdomain.

    I will add just theme and yoast plugin and try to add it on Cloudflare again to see nif thjis is going to happend again.
     
  9. Leila

    Leila Member

    Joined:
    Aug 11, 2017
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Croatia
    cPanel Access Level:
    Website Owner
    And to close this jurney with Cloudflare, here how it went in the end. So I tried to install new subdomain in my cPanel,when my Nameservers were still Cloudflare's and I did it, BUT! I could not login to my WP subdomain dashboard. It would not open that site, just blank site, nothing. So I tried in Firefox also nothing.

    Then I said to my self, life is to short for this and my nerves are to precious for this crap of service. After 4 days still no answer from Cloudflare support and I have open ticket.

    So I change back my Nameservers to Hostgator and the life is moving on. I need to make new subdomain from scratch thanks to Cloudflare.

    And how to use subdomain on Cloudflare, very "simple" you just need to purchase SSL certificate by your self then the host or you need to upload it to server and then you can use subdomain on Cloudflare with no worries. This I have discovered after Tech Suport from my host tried to save my subdomain. But since Cloudflare did not make their service thru the end, meaning it is not working on subdomains like on main domains and I could not make my new subdomain work while I had Cloudflare's Nameservers. So I changed my Nameservers back to my hosts.

    So to conclude don't put your subdomain on Cloudflare it is not worth the nerves, time and your effort.
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,165
    Likes Received:
    1,371
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @Leila,

    I moved these posts to a separate thread, as it seems unrelated to the issue described in the original thread they were posted to. Let us know if we can be of any further assistance.

    Thank you.
     
Loading...

Share This Page