The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL Issue

Discussion in 'General Discussion' started by onaweb, Jun 15, 2006.

  1. onaweb

    onaweb Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Hello,
    Ok, I have searched this forum, but everything that I have tried so far does not fix the issue.

    Here's the issue. I have installed a SSL cert, everything went fine. I purchased the cert from Geotrust but did not install the CA with it.

    IF we try to view the secure url https://linux2.onahosting.com, everything is fine. When we click the padlock icon in IE, it shows that the cert is valid, it is from a trusted source, etc. We have tried accessing it from every computer in the office, tried it from home, it works everytime - although you will get the standard cpanel - no website is configured. When my client tries to access the site from his computer, he gets a this page can not be displayed. I thought maybe it was the CA bundle so I overwrote the cert and used the CA bundle, I checked the httpd.conf and the CA is corrected referenced.

    We thought for sure that it was a firewall setting on his end, however if I ask him to bring up https://dserv.onahosting.com, my other server, it loads up just fine. The only difference is that the dserv.onahosting.com cert is purchased via Thawte instead of Geotrust.

    The problem that we are having is that we set up a custom shopping cart for our client and everything works fine until they have to click the checkout button to enter their credit card. At that point they are transferred from the non-secure server to the secure server, for them it just hangs. For us, it works just fine.

    Thank you,
    Andy
     
  2. luis

    luis Well-Known Member

    Joined:
    Sep 3, 2001
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    I'm pretty sure your client is using a web browser that does not support Geotrust certs... old browsers, Mac browsers, etc. That is the reason he can see the thawte one... thawte and verisign are the most compatible certs.
     
  3. onaweb

    onaweb Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Ok, I fixed that issue - I order a cert from Thawte instead. Works great. But now I am having a different issue.

    Here is what I'm doing. I have a linux server that we are migrating to two separate servers to upgrade hardware and reduce load. So I am moving all sites on server #1 to server #2 and server #3.

    I had problems with the cert on #2, but after installing a cert from Thawte haven't had any issues (at least that I know of).

    For server #3, I purchased a Thawte cert the same day and installed it the same day as server #2. The problem I am having is that if I go the hostname such as https://linux2.onahosting.com or https://linux3.onahosting.com, both come up with the Cpanel "There is no website configured for this address" - which is fine.

    The problem lies in the accessing the accounts on each server. If I go to https://linux2.onahosting.com/~smsun2/ the site comes up. but if I go to https://linux3.onahosting.com/~abeei2/ it comes up as a 404 page not found.

    I have checked the httpd.conf file, both are identical except for the IPs and servername in all references to the SSL. I have checked and SSL Module is enabled for both for Apache, both servers have port 443 open in firewall, I have restart apache with the startssl.

    I have searched this forum, but so far everything that I have found has not been any help.

    Thank you,
    Andy
     
  4. onaweb

    onaweb Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Figured it out, my specific problem was the mod protect setting under tweak security.
     
Loading...

Share This Page