SSL Not active anymore on my WHM

360webfirm

Well-Known Member
Oct 5, 2016
73
3
8
Ottawa
cPanel Access Level
Root Administrator
Hello,

I noticed a few days ago that my SSL is not active on my WHM anymore. This use to be green padlock and secure, now its showing https:// with a red line through and ask me to verify if I want in..

I just purchased another account for another customer and it too is not green pad locked, but shows warning when logging in and not secure anymore.

Anyone know what is going on?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello,

Could you provide some more information about the system and the URL you are using to access Web Host Manager? For instance, is it through an individual domain name, or the server's hostname? Also, are you using port 2087 in the URL, or accessing it over "whm.domain.tld"? Please post the output from the following command as well:

Code:
cat /usr/local/cpanel/version
Thank you.
 

360webfirm

Well-Known Member
Oct 5, 2016
73
3
8
Ottawa
cPanel Access Level
Root Administrator
I am trying to access my site like this https://xxxxx.vps.ovh.ca:2087/ and this is a NEW server for another customer and I got an email with a certificate, did autofill and seemed to work, restarted services and still not green pad lock. I am also failing BIG time with PCI Compliance after moving a customers website over from plesk to C Panel and it made it worse.

I have another server main VPS server using c panel and it was always green pad lock until recently and I did not change anything or the url I go to for it. Got an email about this also and said c panel will install, but that had been close to a week ago!

I just want my server secure, green pad locked, and be able to pass the PCI compliance stuff for the new customer.
 

24x7server

Well-Known Member
Apr 17, 2013
1,911
97
78
India
cPanel Access Level
Root Administrator
Twitter

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
I am trying to access my site like this https://xxxxx.vps.ovh.ca:2087/ and this is a NEW server for another customer and I got an email with a certificate, did autofill and seemed to work, restarted services and still not green pad lock.
Hello,

Does the other server also use a hostname with the provider's domain name? If not. you may need to change the hostname on the server so that it utilizes it's own domain name instead of the one offered by the provider. You can read more about the hostname SSL certificate at:

Free cPanel-Signed Hostname Certificate - cPanel Knowledge Base - cPanel Documentation

Thank you.