The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ssl not working properly

Discussion in 'General Discussion' started by waddtown, Feb 22, 2006.

  1. waddtown

    waddtown Registered

    Joined:
    Feb 22, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
  2. elliotcooper

    elliotcooper Well-Known Member
    PartnerNOC

    Joined:
    May 18, 2005
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    The problem could be caused because you are not using the hostname that you registered the cert to in your html. Your cert is registered to www.ukcelticjewellery.co.uk but you have this line in the html of the home page:

    <base href="https://ukcelticjewellery.co.uk/" />

    Try editing that to:

    <base href="https://www.ukcelticjewellery.co.uk/" />

    and see if you get the same error.
     
  3. adept2003

    adept2003 Well-Known Member

    Joined:
    Aug 11, 2003
    Messages:
    283
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    ~ "/(extra|special)/data"
    THis isn't an issue due to cPanel. If you look at the source code on the page, you have urls in the form https://ukcelticjewellery.co.uk. This will create the message you see since the SSL certificate is for https://www.ukcelticjewellery.co.uk.

    To correct the issue, you should edit your zencart configuration to include the "www" bit of the url.

    Regards,
     
  4. waddtown

    waddtown Registered

    Joined:
    Feb 22, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    thanks for that just me beiung stupid I thought I had edited it but i must one.
    Just one other quick question I am right in thinking that the files for ssl still go in the public html folder. If so why would the https version be displaying differently to the http. I get pictures appearing at the bottom of https://www.ukcelticjewellery.co.uk that are not there on http://www.ukcelticjewellery.co.uk. even though there is no reference to these pictures anywhere in the website.
     
  5. adept2003

    adept2003 Well-Known Member

    Joined:
    Aug 11, 2003
    Messages:
    283
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    ~ "/(extra|special)/data"
    again - not a cpanel issue. There will be a reference to these images somewhere in your ZenCart installation... best speaking to your web designer or web host, since without any access to the site we can only guess, guess, and keep guessing!
     
Loading...

Share This Page