The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ssl problem - cert install

Discussion in 'General Discussion' started by EMS, Mar 2, 2005.

  1. EMS

    EMS BANNED

    Joined:
    May 10, 2003
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    I just installed a certificate via WHM. Something I've done many times before with no problems. The procedure went fine but when I try to navigate to the domain using https://domain.com I simply get a cannot find server message.

    Ive checked the httpd.conf and all looks fine. I've restarted the relevent services. Ive cleared out the certs manually and installed it again still no joy.

    This is simply a re - issued certificate as the domain moved servers. I was sure to clear out the previous certs and keys for the domain before installing this one.

    Any ideas ?
     
  2. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    this may seem like a dumb question but is it on its own dedicated IP
     
  3. EMS

    EMS BANNED

    Joined:
    May 10, 2003
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    0
    I'm glad you asked that becasue this may be the problem.

    Usually, I can get away with installing one certificate on the server IP, then any subsequent certs I use an extra IP.

    Is this no longer the case ?
     
  4. brianc

    brianc Well-Known Member

    Joined:
    May 16, 2003
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Same problem

    I got the exact same problem. I am trying to installed a renewed cert and I cannot get this client's ssl server to start. It is on its own IP btw.

    EMS - Did you work out your problem?

    Brian
     
  5. brianc

    brianc Well-Known Member

    Joined:
    May 16, 2003
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Problem solved

    Solved my own problem. Apparently Comodo updated their CABundle cert, so when I installed the renewed cert, it would not work with the existing CA Bundle cert like others I have done in the past. So I went ahead and installed the CA Bundle that came with the renewed cert and all is well.

    Brian
     
  6. EMS

    EMS BANNED

    Joined:
    May 10, 2003
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    0
    This was the same problem for me. I edited the bundle file for the domain with the new comodo CA cert and it worked !!

    Thanks for the heads up.

    For anyone else who needs to do this, heres what you do...

    1. Get the latest comodo CA from here http://www.instantssl.com/ssl-certificate-support/cert_installation/ssl-certificate-index.html

    2. In /usr/share/ssl/certs for the domain you are having a problem with, there will be a file named yourdomain.cabundle simply edit this file, copying the new cert over the old one.

    3. Restart apache

    Dont use WHM to do this - pasting the new cert in the bottom box of the certificate install page will not overwrite the old cert.
     
    #6 EMS, Mar 3, 2005
    Last edited: Mar 3, 2005
Loading...

Share This Page