The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL problem

Discussion in 'Security' started by lakridserne, Jan 4, 2011.

  1. lakridserne

    lakridserne Member

    Joined:
    Dec 3, 2009
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I have been able to set a cPanel up with a valid SSL certificate. It also redirects to the hostname if I type /cpanel and so on, but not if I type domain.com:2082 or domain.com:2083.

    Is it possible to fix.
     
  2. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    You can change this behavior in the WebHost Manager by clicking Main >> Server Configuration >> Tweak Settings and changing the value for Require SSL from Off to On. This will require log-ins to cPanel, the WebHost Manager and Webmail to take place on the secure ports (2083, 2087 and 2096, respectively).
     
  3. lakridserne

    lakridserne Member

    Joined:
    Dec 3, 2009
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    It is already set to on. Let me Try to explain.

    The SSL certificate is installed on the Hostname both as all service certificates and as a normal SSL certificate that is shared.

    When I go to website.com:2087, it should redirect to the hostname, but instead, it just say that the certificate is registered to the hostname.
     
  4. lakridserne

    lakridserne Member

    Joined:
    Dec 3, 2009
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Anyone who can help me with this?
     
  5. lakridserne

    lakridserne Member

    Joined:
    Dec 3, 2009
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I solved this problem by installing a wildcard SSL
     
Loading...

Share This Page