The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL secure pop - outlook express

Discussion in 'General Discussion' started by jamesbond, Nov 24, 2002.

  1. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    Hi,

    I installed a instant ssl certificate through WHM, and when I use secure pop in outlook express I get the following warning.

    &A Certificate chain processed correctly, but terminated in a root
    certificate which is not trusted by the trust provider. &

    I am not supposed to get this warning.

    By the way, https works fine, expept for the &client authentication& window that pops up when connecting to port 2083 and 2087

    I'm running : WHM 5.3.0 Cpanel 5.3.0-R56 RedHat 7.3

    How to fix this server side?
     
  2. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    From testing awhile ago it seemed that the server always used whatever certificate was setup for the whole server (the WHM/CPanel certificate) and not the one assigned to a particular domain. This was just for e-mail, the separate certificates still worked for connecting securely through a browser.
     
  3. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    thaphantom,

    it's an instantssl cert, I know it has something to do with the root cert not being trusted.
    Which shouldn't be the case with outlook express 6.

    I had the same problems with port 2083 and 2087, that has been fixed in R56, maybe they forgot to look at secure pop :)
     
  4. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    [quote:b19019aa0a][i:b19019aa0a]Originally posted by JustinK[/i:b19019aa0a]

    From testing awhile ago it seemed that the server always used whatever certificate was setup for the whole server (the WHM/CPanel certificate) and not the one assigned to a particular domain. This was just for e-mail, the separate certificates still worked for connecting securely through a browser.[/quote:b19019aa0a]

    Hi Justin,

    Actually I'm using the server wide WHM/CPanel certificate in outlook express.
    I would like to provide this as a service to my customers as an option, using host.servername.com as secure pop server

    It's probably due to the way WHM installs the cert, as I said they fixed the &trust warning& for port 2083/2087.

    If there any other people with instantssl certs, could you try secure pop and see if you get the same warning?
     
  5. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    secure pop works without any warnings now! :)

    I had the wrong settings for the account I was checking because I somehow mixed up 2 accounts in my outlook express...

    Sorry to bother with you with this.
     
  6. moronhead

    moronhead Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    706
    Likes Received:
    0
    Trophy Points:
    16
    007,

    What settings do you use (port and mailserver) for POP3 and SMTP for secure mail in the email client ?

    Regards,
    Norman
     
  7. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    [quote:85004660f3][i:85004660f3]Originally posted by moronhead[/i:85004660f3]
    What settings do you use (port and mailserver) for POP3 and SMTP for secure mail in the email client ?
    [/quote:85004660f3]

    POP3 : port 995 and SMTP : port 465

    Everything is working fine. The warnings I got were due to a mixup of 2 email accounts.
     
  8. moronhead

    moronhead Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    706
    Likes Received:
    0
    Trophy Points:
    16
    Thanks for the info.

    I don't know if James Bond is your real name or not. I'm just assuming you're a 007 fan. ;) Sorry if I'm wrong.

    Regards,
    Norman
     
  9. ozzi4648

    ozzi4648 Guest

    [quote:aad4c01f1c][i:aad4c01f1c]Originally posted by jamesbond[/i:aad4c01f1c]

    secure pop works without any warnings now! :)

    I had the wrong settings for the account I was checking because I somehow mixed up 2 accounts in my outlook express...

    Sorry to bother with you with this.
    [/quote:aad4c01f1c]

    Can you tell us what you did? I get the warnings in outlook. Can you show us what you used in outlook express? Did you also setup a cert using stunnel?
     
  10. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    [quote:8b147a551d]
    Can you tell us what you did? I get the warnings in outlook. Can you show us what you used in outlook express? Did you also setup a cert using stunnel?[/quote:8b147a551d]

    I installed an InstantSSL cert for the server domain

    All I did is enter the serverdomain for pop3 (port 995)and smtp (port 465)

    That's it.
     
  11. ozzi4648

    ozzi4648 Guest

    [quote:304a53c52d][i:304a53c52d]Originally posted by jamesbond[/i:304a53c52d]

    [quote:304a53c52d]
    Can you tell us what you did? I get the warnings in outlook. Can you show us what you used in outlook express? Did you also setup a cert using stunnel?[/quote:304a53c52d]

    I installed an InstantSSL cert for the server domain

    All I did is enter the serverdomain for pop3 (port 995)and smtp (port 465)

    That's it.
    [/quote:304a53c52d]

    Yep worked it out after i posted. For incoming outgoing mailserver in Outlook one my pop the servers host eg host.mydomain.com instead of mail.yourdomain.com. Then stunnel is called via SSL
     
Loading...

Share This Page