SSL stuff not working anymore in CPanel

Guru Evi

Registered
Apr 21, 2006
2
0
151
Last night something happened and as of this morning our SSL stuff is not working anymore.

cpsrvd-ssl gives the following error: /usr/local/cpanel/cpsrvd-ssl: error while loading shared libraries: /usr/local/cpanel/perl/Net/SSLeay/SSLeay.so: cannot open shared object file: No such file or directory

httpd will also not start with /etc/init.d/httpd --startssl (segfaults)

I have reinstalled SSLeay through RPM, run all fixperl scripts in the /scripts directory, reinstalled SSLeay again through CPAN and that recompiled the whole thing, ran again all fixperl scripts. SSLeay works in general, it is just not to be found in in /usr/local/cpanel/perl/ (there is not even a directory Net there). The module can be found on the disk:

/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/auto/Crypt/SSLeay/SSLeay.so
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/auto/Net/SSLeay/SSLeay.so

Does anyone have any idea where to look or what to do. I also rebooted the whole server. The only thing I can find is that yum yesterday had some updates, but nothing to do with SSLeay. And yesterday it was still working.


Apr 20 14:42:56 Dep Installed: perl-XML-Dumper 0.4-25.noarch
Apr 20 14:42:56 Dep Installed: perl-libxml-enno 1.02-29.noarch
Apr 20 14:42:56 Dep Installed: perl-HTML-Tagset 3.03-28.noarch
Apr 20 14:42:56 Dep Installed: Omni-foomatic 0.7.2-4.i386
Apr 20 14:42:56 Dep Installed: perl-HTML-Parser 3.26-17.i386
Apr 20 14:42:56 Dep Installed: perl-libwww-perl 5.65-6.noarch
Apr 20 14:42:56 Dep Installed: gail 1.2.2-1.i386
Apr 20 14:42:56 Dep Installed: mpage 2.5.3-3.i386
Apr 20 14:42:56 Dep Installed: pnm2ppa 1:1.04-7.i386
Apr 20 14:42:56 Dep Installed: perl-DateManip 5.42a-0.rhel3.noarch
Apr 20 14:42:56 Dep Installed: gtkhtml2 2.2.0-6.i386
Apr 20 14:42:56 Dep Installed: perl-libxml-perl 0.07-28.noarch
Apr 20 14:42:56 Dep Installed: perl-XML-Twig 3.09-3.noarch
Apr 20 14:42:56 Dep Installed: foomatic 2.0.2-15.1.1.i386
Apr 20 14:42:56 Dep Installed: perl-XML-Grove 0.46alpha-25.noarch
Apr 20 14:42:56 Dep Installed: perl-Parse-Yapp 1.05-30.noarch
Apr 20 14:42:56 Dep Installed: perl-XML-Encoding 1.01-23.noarch
Apr 20 14:42:56 Dep Installed: perl-XML-Parser 2.31-15.i386
Apr 20 14:42:56 Dep Installed: gnome-python2-gtkhtml2 1.99.14-5.i386
Apr 20 14:42:56 Updated: cups 1:1.1.17-13.3.37.i386
Apr 20 14:42:56 Updated: samba-client 3.0.9-1.3E.7.i386
Apr 20 14:42:56 Updated: libstdc++ 3.2.3-54.i386
Apr 20 14:42:56 Updated: binutils 2.14.90.0.4-42.i386
Apr 20 14:42:56 Updated: libstdc++-devel 3.2.3-54.i386
Apr 20 14:42:56 Updated: openldap 2.0.27-22.i386
Apr 20 14:42:56 Updated: libgcc 3.2.3-54.i386
Apr 20 14:42:56 Updated: cups-libs 1:1.1.17-13.3.37.i386
Apr 20 14:42:56 Updated: vixie-cron 4.1-10.EL3.i386
Apr 20 14:42:56 Updated: XFree86-libs-data 4.3.0-98.EL.i386
Apr 20 14:42:56 Updated: XFree86-xfs 4.3.0-98.EL.i386
Apr 20 14:42:56 Updated: up2date 4.4.67-3.centos.1.i386
Apr 20 14:42:56 Updated: krb5-workstation 1.2.7-52.i386
Apr 20 14:42:56 Updated: pam-devel 0.75-67.i386
Apr 20 14:42:56 Updated: ntsysv 1.3.13.3-0.3.i386
Apr 20 14:42:56 Updated: glibc 2.3.2-95.39.i686
Apr 20 14:42:56 Updated: comps 3.7centos.0-0.20060403.i386
Apr 20 14:42:56 Updated: XFree86-devel 4.3.0-98.EL.i386
Apr 20 14:42:56 Updated: hwdata 0.101.22-1.noarch
Apr 20 14:42:56 Updated: samba-common 3.0.9-1.3E.7.i386
Apr 20 14:42:56 Updated: gcc 3.2.3-54.i386
Apr 20 14:42:56 Updated: samba-swat 3.0.9-1.3E.7.i386
Apr 20 14:42:56 Updated: chkconfig 1.3.13.3-0.3.i386
Apr 20 14:42:56 Updated: XFree86-truetype-fonts 4.3.0-98.EL.i386
Apr 20 14:42:56 Updated: gnupg 1.2.1-15.i386
Apr 20 14:42:56 Updated: nfs-utils 1.0.6-43EL.i386
Apr 20 14:42:56 Updated: krb5-devel 1.2.7-52.i386
Apr 20 14:42:56 Updated: openldap-clients 2.0.27-22.i386
Apr 20 14:42:56 Updated: nscd 2.3.2-95.39.i386
Apr 20 14:42:56 Updated: iputils 20020927-11.30.4.i386
Apr 20 14:42:56 Updated: glibc-devel 2.3.2-95.39.i386
Apr 20 14:42:56 Updated: psacct 6.3.2-35.rhel3.i386
Apr 20 14:42:56 Updated: samba 3.0.9-1.3E.7.i386
Apr 20 14:42:56 Updated: glibc-common 2.3.2-95.39.i386
Apr 20 14:42:56 Updated: python 2.2.3-6.2.i386
Apr 20 14:42:56 Updated: python-devel 2.2.3-6.2.i386
Apr 20 14:42:56 Updated: GConf2 2.2.1-4.1E.i386
Apr 20 14:42:56 Updated: redhat-config-printer 0.6.47.3.31-1.i386
Apr 20 14:42:56 Updated: initscripts 7.31.30.EL-1.centos.1.i386
Apr 20 14:42:56 Updated: cpp 3.2.3-54.i386
Apr 20 14:42:56 Updated: rhnlib 1.8.2-1.p22.1.noarch
Apr 20 14:42:56 Updated: XFree86-Mesa-libGL 4.3.0-98.EL.i386
Apr 20 14:42:56 Updated: findutils 1:4.1.7-9.1.i386
Apr 20 14:42:56 Updated: netdump-server 0.7.14-3.i386
Apr 20 14:42:56 Updated: centos-release 3:3-7.1.i386
Apr 20 14:42:56 Updated: tzdata 2006a-1.EL3.noarch
Apr 20 14:42:56 Updated: libgcj 3.2.3-54.i386
Apr 20 14:42:56 Updated: netdump 0.7.14-3.i386
Apr 20 14:42:56 Updated: sysreport 1.3.7.2-13.noarch
Apr 20 14:42:56 Updated: bash 2.05b-41.5.centos.0.i386
Apr 20 14:42:56 Updated: XFree86-libs 4.3.0-98.EL.i386
Apr 20 14:42:56 Updated: ypbind 3:1.12-5.21.9.i386
Apr 20 14:42:56 Updated: glibc-headers 2.3.2-95.39.i386
Apr 20 14:42:56 Updated: gcc-c++ 3.2.3-54.i386
Apr 20 14:42:56 Updated: diskdumputils 1.2.8-1.i386
Apr 20 14:42:56 Updated: redhat-config-printer-gui 0.6.47.3.31-1.i386
Apr 20 14:42:56 Updated: krb5-libs 1.2.7-52.i386
Apr 20 14:42:56 Updated: centos-yumcache 3.1-0.20060404.3.noarch
Apr 20 14:42:56 Updated: shadow-utils 2:4.0.3-26.RHEL3.i386
Apr 20 14:42:56 Updated: pam 0.75-67.i386
Apr 20 14:42:56 Updated: autofs 1:4.1.3-168.i386
Apr 20 14:42:56 Updated: XFree86-font-utils 4.3.0-98.EL.i386
Apr 20 14:42:56 Updated: man 1.5k-13.rhel3.i386
Apr 21 09:36:51 Installed: perl-Crypt-SSLeay 0.51-4.i386

My kernel version:
2.4.21-32.0.1.EL #1 on a CentOS distribution. Cpanel X etc., we do the automatic updates with Cpanel but I have no idea what went wrong.

Does anyone have any idea?

Thank you
 
Jan 18, 2006
15
0
151
I am getting the exact same error with Fedora Core 4 and WHM 10.8.0 cPanel 10.8.1-R113
Fedora i686 - WHM X v3.1.0

I am going to try changing from RELEASE to CURRENT in hopes of a fix.
 

Guru Evi

Registered
Apr 21, 2006
2
0
151
I wrote cPanel (Support Ticket) and this was their answer:


I recompiled Apache using your previous Config and that resolved the problem.

the /usr/local/cpanel/cpsrvd-ssl will always produce that error as its not used that way, you can just type /etc/init.d/cpanel restart and it will restart cPanel SSL Services.
Hope this helps someone