Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL verify error: certificate name mismatch

Discussion in 'E-mail Discussions' started by kernow, Feb 15, 2017.

  1. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    907
    Likes Received:
    13
    Trophy Points:
    168
    cPanel Access Level:
    Root Administrator
    For the last few days some mail sent out is not being delivered due to SSL cert mismatch, example from logs:
    SSL service cert supplied by cpanel Any ideas?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    The SSL warnings should not actually prevent delivery. Instead, it looks to relate to the following error:

    This message often appears when the system lacks a valid RDNS entry for the IP address used to send email. Check to ensure a RDNS record exists from the IP address used for sending email to the proper hostname. Your data center or hosting provider can help you to setup the record.

    You may also want to verify you can connect to that remote mail server over port 25 by running the following command from your system:

    Code:
    telnet remote-mail-host 25
    Thank you.
     
  3. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    907
    Likes Received:
    13
    Trophy Points:
    168
    cPanel Access Level:
    Root Administrator
    Hello,
    We don't like the security implications of installing telnet. However the server does have a valid PTR (reverse DNS) record. Also the SSL warning is preventing the mail from being delivered as it remains in the mail queue for a few days and resending/forcing just returns the same error.
    EDIT
    After restarting exim and forcing a mail run, the mail is now delivered. Go figure ........
     
    #3 kernow, Feb 16, 2017
    Last edited: Feb 16, 2017
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Let us know if you encounter any additional issues.

    Thank you.
     
Loading...

Share This Page