The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL Wildcard

Discussion in 'Security' started by thomas_a_bunn, May 6, 2010.

  1. thomas_a_bunn

    thomas_a_bunn Registered

    Joined:
    May 6, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    We recently installed a Digicert wildcard SSL certificate on our Cpanel/WHM 11.25.0 environment, however we are running into some issues. The certificate installed successfully but whenever you browse to a site over SSL it is redirecting to domain.com/cgi-sys/defaultwebpage.cgi.

    What we would like to accomplish is that all of our sites will use this wildcard certificate globally without having to configure something manually for each account.

    Any help with this would be greatly appreciated.

    Thanks!
     
  2. thewebhostingdi

    thewebhostingdi Well-Known Member

    Joined:
    Jan 10, 2008
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Please make sure that the dedicated IP address is assigned properly to the domain. It seems that the dedicated IP address is not configured properly in your httpd.conf file. You can try to reassign the dedicated IP address to your account and have a try.
     
  3. thomas_a_bunn

    thomas_a_bunn Registered

    Joined:
    May 6, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Thanks very much for your suggestion. Before I proceed any further, can you specify what you mean by suggesting we "reassign our dedicated IP to the domain"?
     
  4. DomineauX

    DomineauX Well-Known Member
    PartnerNOC

    Joined:
    Apr 12, 2003
    Messages:
    414
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    As you mentioned having the wildcard ssl installed on the server host name for WHM/CPanel/Webmail I expect your issue is most likely caused by having the SSL redirect option set to redirect to the original domain when accessed instead of either host name of the server or the host name of the certificate.

    Changing it to redirect to the server host name instead is the way to avoid the trouble you are having.

    ps. Also setting it to redirect to the host name of the SSL cert has trouble with wildcard ssl's so that could be the problem so in either case set it to redirect to host name (in tweak settings).
     
  5. thomas_a_bunn

    thomas_a_bunn Registered

    Joined:
    May 6, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the quick response. After taking a look in the tweak settings configuration, under Redirection we had the SSL redirect to SSL Certificate Name. So from your advice, I changed this to Hostname, which didn't change anything. When I try to access the page over SSL I am still getting redirected to https://domain.com/cgi-sys/defaultwebpage.cgi. I did notice that the setting for visiting without SSL is set to Origin Domain Name. Should I set this to Hostname as well?

    Thanks!
     
Loading...

Share This Page