The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL Woes..

Discussion in 'General Discussion' started by chae, Oct 6, 2004.

  1. chae

    chae Well-Known Member

    Joined:
    Apr 19, 2003
    Messages:
    145
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Auckland, New Zealand
    Hi Yah,

    Over the last few days SSL Certs have stopped working for what seems no apparent reason. When any SSL pages is called on any domain (shared cert or dedicated cert) it comes back with a DNS error.

    I go into WHM reinstall the certs and it works fine. Some of these certs have been running for near on a year without any issues.

    The only thing that's changed on the box is the last few big UPCP upgrades, running latest current version and the installation of PRM & SIM. The http rule in PRM is as follows:-

    # seconds to wait before rechecking a flaged pid (pid's noted resource
    # intensive but not yet killed).
    WAIT="15"

    # counter limit that a process must reach prior to kill. the counter value
    # increases for a process flaged resource intensive on rechecks.
    KILL_TRIG="3"

    # argument to pass onto kill commands
    KARG="9"

    # Max CPU usage readout for a process - % of all cpu resources (decimal values unsupported)
    MAXCPU="65"

    # Max MEM usage readout for a process - % of system total memory (decimal values unsupported)
    MAXMEM="45"

    # Max processes for a given command - this is not max processes for user but rather the executable
    MAXPS="65"

    I wouldn't have thought this would kill any https connections or make SSL stop.

    Anyone else had any problems with SSL dying like this?

    Thanks in advance
     
  2. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    If I remember correctly, SIM doesn't restart http with ssl support. You might want to re-check this.
     
  3. chae

    chae Well-Known Member

    Joined:
    Apr 19, 2003
    Messages:
    145
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Auckland, New Zealand
    Hi Yah Haze,

    Thanks you put me on the right track :)

    Seems the latest version on the developers web site is 2.5.x and that doesn't support the https restart. Went into their forums and did a search to see if anyone else was having issues with ssl and came across this post...

    http://forums.rfxnetworks.com/viewtopic.php?t=219

    There's now a version 3 of SIM out and the download link is in the posts. The documentation is scarce but the config files look straight forward enough, though I did notice on my install it didn't add the cron job, plus I had to make a wee change to the http module to cater for the https.

    I'm going to chase the developers up to see if we can get more detailed documentation.

    Now just have to wait and see if it works okay :D
     
Loading...

Share This Page