The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSL_Base in buildapache

Discussion in 'EasyApache' started by Stevez, Nov 1, 2004.

  1. Stevez

    Stevez Active Member

    Joined:
    Jun 25, 2004
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Hi People,

    I run freebsd with latest release build of cpanel.

    Every time i want to update apache i have to do it manually because when you install openssl on freebsd (ports) it installs it to prefix /usr/local

    In easyapache it sets
    SSL_BASE=/usr

    When easyapache runs it trys to run configure on apache and gets the following error

    Error: Cannot find SSL binaries under /usr

    The script goes on thinking it went fine then trys to make apache, because the configure did not finish make will have no files to run off so make will not run. AGAIN easyapache thinks this is not a problem and still trys to install php and so forth..

    I posted this a while ago but cpanel has not fixed it yet.

    Looking at buildapache.sea it has nothing about ssl at the top of the file.. the rest is a binary file so yeh..

    Just wondering if anyone knows how to change it, then ill submit a bug report to cpanel.
     
  2. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    I hate to bring an old thread up again but this is happening to us on a Freebsd 5.4 box. When we run easyapache we can see it telling us it cant find the binaries in /usr but it should be /usr/local. Apache build dies and the rest of the stuff compiled but we are left with the old
    version of apache.

    Anyone know how to change the SSL_BASE variable when running easyapache ?
     

Share This Page