The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Starttls

Discussion in 'General Discussion' started by tprice42, Oct 13, 2005.

  1. tprice42

    tprice42 Active Member

    Joined:
    Sep 10, 2004
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Hi all, i've currently got a problem with TLS with exim which is when STARTTLS is requested by remote smtp servers they get 'Connection closed by foreign host' without any error message either on their end or in my logs.

    In my exim.conf file i can change the following line:
    tls_advertise_hosts = *

    to:
    tls_advertise_hosts =

    to fix the problem but this tends to get reset back to the first line in the nightly updates from what i can tell.

    My cPanel and WHM ssl certs recently expired and i don't know if that is related but i have regenerated them and also copied them to the exim.key and exim.crt files just in case this would work... It didn't.

    I have tried the /scripts/eximup script and the /scripts/rebuildeximbsd script but neither has worked.

    I'm running FreeBSD 5.2.1 with WHM 10.1.0 & cPanel 10.2.0-S83

    If anyone has any ideas i would love to hear from you, I'm thinking that re-generating the ssl keys for exim might be an order but i don't know how.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I can help with the workaround. If you put the following into WHM > Exim Configuration Editor > Advanced Mode > first textbox:

    tls_advertise_hosts =

    Then it won't be wiped out after upcp runs.

    As the the actual problem, which version of exim are you actually running:

    exim -bV
     
  3. tprice42

    tprice42 Active Member

    Joined:
    Sep 10, 2004
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    I've added the lines to the advanced exim editor and that seams to work fine. Thanks

    Exim version 4.53 #0 (FreeBSD 5.2.1) built 01-Oct-2005 04:20:03
     

Share This Page