The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Statistics Software Configuration

Discussion in 'General Discussion' started by mallman, Dec 22, 2006.

  1. mallman

    mallman Registered

    Joined:
    Nov 29, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    We are still getting this email message.
    See below.

    The Statistics Software Configuration is not keeping up at setting 24 hours.
    I changed to 48 hours and it did ok for 1 day.
    Now it can not kept up again.

    It says:
    The server is having trouble keeping up with your statistics processing schedule.

    I think this is what is causing the email "below".

    Can anyone help?

    EMAIL:

    IMPORTANT: Do not ignore this email.
    This is cPanel stats runner on server!
    While processing the log files for user webmarke, the cpu has been
    maxed out for more than a 6 hour period. The current load/uptime line on the server at the time of
    this email is
    04:18:37 up 16 days, 11:26, 0 users, load average: 7.82, 3.07, 1.75
    You should check the server to see why the load is so high and take
    steps to lower the load. If you want stats to continue to run even with a high load; Edit
    /var/cpanel/cpanel.config and change extracpus to a number larger then 0 (run
    /usr/local/cpanel/startup afterwards to pickup the changes).
     
  2. ccccanada

    ccccanada Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    It seems pretty clear from the email that the problem is not your statistic software but instead your server load.

    You should try to look into what is cauing the high server load and once you find that out and correct it then your stats should have no problem updating.
     
  3. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    try changing the time your backups run. it looks like it maybe running about the same time the logrotation takes place, which maybe causing your high loads.

    Mickalo
     
  4. GCIS

    GCIS Active Member

    Joined:
    Dec 12, 2006
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    The issue is server load - your server cannot process all of the log files in the time allotted. There are several solutions to this problem:


    1. Change the time of log processing to off-peak hours.
    2. Disable logging for high-traffic domains on which statistics are not needed. Alternatively, you can use an external statistics solution, such as Google's, for managing statistics for high-traffic domains. This will require some manual edits to configuration files.
    3. Get another server.


    Go ahead and try the above steps, in the listed order. If you need any specific how-tos for a listed step, go ahead and ask.
     
Loading...

Share This Page