The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stats/Server Overload

Discussion in 'General Discussion' started by NovemberRain, Jun 4, 2005.

  1. NovemberRain

    NovemberRain Well-Known Member

    Joined:
    Sep 24, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    İstanbul
    cPanel Access Level:
    Root Administrator
    Hello, I have been getting this mail for a few weeks. And the server load is very high since then, sometimes it is between 10-15. The load on the server was always under 2 before.

    But the strange thing for me is, this customer's site is not the biggest site on the server, there are a few sites which are more active and have a higher bandwith usage but I don't get stats warnings for their accounts. I get this mail only for this customer. He has a busy vbulletin forum, but not the busiest one in the server.

    What should I do to lower the load?

    Server: P4 3.2 HT / 1 GB RAM / 120GB SATA / eaccelator installed

    Thank you.
     
  2. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India

    Please go to WHM >> Twek settingss >> select the option

    Delete each domain's access logs after stats run

    Also check the domlogs for that domain and clear it . It might be very large.

    Also you can use the addon module log sheduler to shedule the times ..where the stats have to run. You can shedule it for the less busy times

    -----
    Aby :)
     
  3. NovemberRain

    NovemberRain Well-Known Member

    Joined:
    Sep 24, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    İstanbul
    cPanel Access Level:
    Root Administrator
  4. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    np :) if mysuggestions helped you.
     
  5. NovemberRain

    NovemberRain Well-Known Member

    Joined:
    Sep 24, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    İstanbul
    cPanel Access Level:
    Root Administrator
    I did everything you said and I am still receiving those mails. I used log sheduler and set it to process the stats in less busy hours. But no help. Is it possible to disable stats processing for a spesific domain? Or is there anything else I should do?

    Thanks
     
  6. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    How much is the size of the log of the domain in question?

    -----
    Aby,
     
  7. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    About the issue of disabling the stats for a particular domain, i 'll give you a way. but it is not official or i don't promise
    it is proper and won't have any other effects.

    Delete all log files and directory (keep /tmp) for the account. then chattr +i tmp directory.

    ------
    Aby,
     
    #7 aby, Jun 9, 2005
    Last edited: Jun 9, 2005
  8. NovemberRain

    NovemberRain Well-Known Member

    Joined:
    Sep 24, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    İstanbul
    cPanel Access Level:
    Root Administrator
    It is only 48 MB

    I have another domain, the log file of that domain is 460mb at the moment. But I am not getting mails for that domain.
     
  9. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Not sure though.... But did you enable the option of deleting the logs after the stats have run....

    But since it is only 46 mb that should not make any issue........
    Also what version of the cpanel are you running..... try updating.the cpanel. It can help...

    -
    Aby :)
     
  10. NovemberRain

    NovemberRain Well-Known Member

    Joined:
    Sep 24, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    İstanbul
    cPanel Access Level:
    Root Administrator
    Yes I enabled that option.

    I am running the latest release. :)
     
  11. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Now you can try disabling the stats for that domain if that is not so important for you. But i know that is not an appreciable solution to the issue, but will help your case. This is all i can see from here with out looking into the server.
    ----
    Aby :)
     
  12. LaZogNa

    LaZogNa Member

    Joined:
    Aug 19, 2003
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Hey I've been getting the same message for a few weeks too... driving me nuts =( What I do is try to reboot it every other day now like its a windows machine or something... one time i didnt do it for awhile and the server locked hard, had to call for colo guys to reboot manually... im using the "current" cpanel release with security updates set on auto

    here is the emails i get

    IMPORTANT: Do not ignore this email.
    This is cPanel cpuwatch on shaka.anykinehosting.com!
    While processing, the cpu has been
    maxed out for more then a 6 hour period. The current load/uptime line on the server at the time of
    this email is
    12:37pm up 1 day, 11:08, 0 users, load average: 1.09, 1.10, 1.09
    You should check the server to see why the load is so high and take
    steps to lower the load. If you want stats to continue to run even with a high load; Edit
    /var/cpanel/cpanel.config and change extracpus to a number larger then 0 (run
    /usr/local/cpanel/startup afterwards to pickup the changes).


    must be a bug huh?

    -=LaZogNa=-
     
  13. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India

    I can't say much without looking into the box. Probably a bug and it is a good idea to open a ticket with the cpanel. They will have some suggestions for you or else you need to have somebody look into your box.

    --------
    Aby :)
     
  14. LaZogNa

    LaZogNa Member

    Joined:
    Aug 19, 2003
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Hey thanks Aby
    Actually I did little tinkering myself and what seemed to help was to delete the largest log in
    usr/local/apache/domlogs and reboot... the log was over 500mb+ which I think was causing the cpu to bog down or get stuck in a cron jop... anyway its been a day now and the root error emails have finally stopped...

    -=LaZogNa=-
     
  15. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    I thought you had done it earlier itself. Anyway glad to know that the issue is fixed.
    -
    Aby :)
     
  16. MMarko

    MMarko Well-Known Member

    Joined:
    Apr 18, 2005
    Messages:
    316
    Likes Received:
    0
    Trophy Points:
    16
    I've noticed on my server one log file which had 1.1GB :)
     
  17. annekmadison

    annekmadison Registered

    Joined:
    Aug 25, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Stats Overload

    I hate to chime in with a "ME TOO" as my very first post, but...ME TOO!

    My observations:

    1) This started "all of a sudden" on 1 August and has been going on ever since, without much help from the support folks.
    2) In my case, it's an apparently random log file--never the same user, it just seems to visit one user one time, another the next. Error messages are generated every six hours, like clockwork, to the point where I've had to install inbox rules just to separate them from my other mail.

    My question:

    1) I've read the advice about deleting logs after each processing, and I've just gone ahead and done that. Is there anything else I can or should do?

    Thanks in advance to all who read this!

    Anne
     
  18. rip_curl

    rip_curl Well-Known Member

    Joined:
    Jan 30, 2005
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    I have same problem with [stats] - email
    now I'm reading tjis topic
    and I'm deleting all logs

    tomorrow i'll tell you about results
     
  19. annekmadison

    annekmadison Registered

    Joined:
    Aug 25, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My problem was related to a cross-site scripting problem with an osCommerce installation. Someone had co-opted the inquiries form and was using it to generate spam. A bug fix was issued by osCommerce.

    Suggestions:
    1) Do a thorough analysis of all scripts in use on your server to ensure that they're not vulnerable to cross-site scripting. Most commonly the form will permit the addition of cr/lf characters in its fields, and these can be used to "hijack" the script. Disable any that cannot be fixed.
    2) Check for security updates for any packages in use that make use of forms.
    3) Acquire, install, and use a package such as RKHUNTER to be certain no rootkits or other undesirable scripts are installed/in use on your server.
    4) Tweak the security settings via cPanel.

    My belief is that by fooling around with the logs and stats, people are treating the symptoms when there may be a real underlying disease--like handing a Band-Aid to someone suffering from cancer. The logs and stats may be telling the truth. In my case, they certainly were.

    Disabling and fixing the culprit forms completely eliminated the problem on my server.

    Regards,
    Anne
     
  20. rip_curl

    rip_curl Well-Known Member

    Joined:
    Jan 30, 2005
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    I moved all logs to another folder
    but mails is still going.
    now I'll be look server load.
     
Loading...

Share This Page