The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stats Stopped - January 14th

Discussion in 'General Discussion' started by alterahosting1, Feb 9, 2004.

  1. alterahosting1

    Joined:
    Jul 24, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    A few of my clients on one of my machines are having problems with both the stats programs on the server. Apparently the stats haven't been updated since Jan 14.

    How do I go about fixing this?

    Note* I don't think this is a server wide issue, only isolated to a few accounts.
     
  2. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Same thing happened on one box of ours...Get this...same exact day 1/14. However, it came back on 1/31 and only effected webelizer. They had the other programs
    to choose from and did not effect those.

    Kinda bizzare if you ask me.
     
  3. mr.wonderful

    mr.wonderful BANNED

    Joined:
    Feb 1, 2004
    Messages:
    345
    Likes Received:
    0
    Trophy Points:
    0
    Me too. One of my resellers losts webalizer stats on all 8 of his domains on Jan 14. Then it just came back mysteriously. We tried resetting his stats using the /scripts/fixwebalizer script which didnt do a thing. I think its working again, after 31st.
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I've just been made aware of one of mine that has no stats either. It says on awstats
    Last Update: 27 Jan 2004 - 01:33
    Needless to say its all zeros for February.

    If you open webalizer for February its a blank page.
     
  5. alterahosting1

    Joined:
    Jul 24, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Same symptoms on my machine.
    Anyone have any ideas?
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    /scripts/fixwebalizer says it will wipe stats. I'm not sure I want to do that so I held off.
    There is no /scripts/awstats AFAIK.

    I sure hope someone's got an idea.
     
  7. alterahosting1

    Joined:
    Jul 24, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
  8. mv2

    mv2 Member

    Joined:
    Feb 4, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    hmm, this sounds like the same thing I'm going through. We've tried all kinds of things to get the stats back, but none of the worked. Febuary stats are non existant. It's very strange that this happened to alot of people all around the same time.
     
  9. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    What happens if you run
    /scripts/runlogsnow
     
  10. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    It has no affect on Feb stats in awstats, but it seems to have fixed Feb in Webalizer.
     
  11. N9ne

    N9ne Well-Known Member

    Joined:
    Jan 7, 2003
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    England
    This problem is a very very very very common problem in cPanel and has been around for months, if not a year +. They still haven't fixed it yet I think it's a big enough bug to be fixed...look at all the people that suffer from it. So far I've been through 5 different cPanel servers - webalizer stopped on all of them at random times, etc.
     
  12. mv2

    mv2 Member

    Joined:
    Feb 4, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    When it stopped for you, did it eventually come back? I've submitted a support ticket over a week ago, posted on here, and still no resolution from cpanel. If they can't fix it, did it at least start working again at some point. I depend on my stats and this is starting to get frustrating.
     
  13. mv2

    mv2 Member

    Joined:
    Feb 4, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hey guys,

    I finally got a resolution from cpanel, and the problem was something I never even thought of. I'll go ahead and post it in case it helps anyone else. It turned out that our stats log file was 2gb which is the max size set in cpanel. That caused the server to stop logging stats because it had nowhere to put them. I run a very busy server, but this never even crossed my mind. Anyway clearing that file has fixed my problem so I thought it might be usefull to pass along.

    Chris
     
  14. mr.wonderful

    mr.wonderful BANNED

    Joined:
    Feb 1, 2004
    Messages:
    345
    Likes Received:
    0
    Trophy Points:
    0
    Rubbish! All server logs, including domlogs are rotated weekly here. How can they say such a ridiculous thing!
     
  15. mv2

    mv2 Member

    Joined:
    Feb 4, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I don't know anything about that, I'm just telling you what they told me. It fixed my problem and I'm happy.
     
  16. furquan

    furquan Well-Known Member

    Joined:
    Jul 27, 2002
    Messages:
    425
    Likes Received:
    0
    Trophy Points:
    16
    This needs serious Attention

    Its affecting every one,


    DARKOB, we hope you are listening !
     
    #16 furquan, Feb 15, 2004
    Last edited: Feb 20, 2004
  17. pingo

    pingo Well-Known Member

    Joined:
    Nov 16, 2002
    Messages:
    430
    Likes Received:
    0
    Trophy Points:
    16
    It turned out that our stats log file was 2gb which is the max size set in cpanel.

    Where is that file located?

    John
     
  18. N9ne

    N9ne Well-Known Member

    Joined:
    Jan 7, 2003
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    England
    Re: This needs serious Attention

    But they don't listen. This problem has existed for what must be more than a year now.
     
  19. furquan

    furquan Well-Known Member

    Joined:
    Jul 27, 2002
    Messages:
    425
    Likes Received:
    0
    Trophy Points:
    16
    My problem is, the stats are being logged, but the COUNTRY is not being displayed. It was working till last November, but not any more.

    Does any one have any clue to this ?
     
  20. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    I've got one account that hasn't processed Webalizer Stats since 12/03. It's processing Analog Stats and Webalizer FTP Stats, just not regular Webalizer Stats. I cannot for the life of me figure out why.

    Is there a master config file somewhere that tells it which accounts to process? The apache log file is for that domain is present and it's only about 1M in size.
     
Loading...

Share This Page